Joel Kitching has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/32262 )
Change subject: vboot: refactor OPROM code ......................................................................
Patch Set 4:
(2 comments)
https://review.coreboot.org/#/c/32262/3/src/security/vboot/common.c File src/security/vboot/common.c:
https://review.coreboot.org/#/c/32262/3/src/security/vboot/common.c@125 PS3, Line 125: int vboot_declares_display(void)
Sorry, I'm still not really happy with the name "declares display". […]
Well, if we want to have a function that fulfills both needs, it could be written like:
*uint32_t flags; vboot_get_flags(flags); *flags |= VBOOT_FLAG_DISPLAY_REQUIRED;
But maybe we should just directly use it:
vboot_get_working_data()->flags |= VBOOT_FLAG_DISPLAY_REQUIRED;
https://review.coreboot.org/#/c/32262/3/src/security/vboot/misc.h File src/security/vboot/misc.h:
https://review.coreboot.org/#/c/32262/3/src/security/vboot/misc.h@37 PS3, Line 37: uint8_t declares_display;
Let's make it a uint32_t flags in case we come up with other one-bit stuff we need to track here lat […]
What's the most acceptable format? I haven't really come across any bit-fields in working with coreboot/vboot/depthcharge so far.