Attention is currently required from: Hung-Te Lin, Jarried Lin.
Yu-Ping Wu has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85951?usp=email )
Change subject: mb/google/rauru: Add edp driver in mainboard ......................................................................
Patch Set 2:
(5 comments)
File src/mainboard/google/rauru/chromeos.c:
https://review.coreboot.org/c/coreboot/+/85951/comment/98991136_feef385b?usp... : PS2, Line 60: struct lb_gpio edp_pwm_gpios[] = { : {GPIO_BL_PWM_1V8.id, ACTIVE_HIGH, -1, "PWM control"}, : }; : lb_add_gpios(gpios, edp_pwm_gpios, ARRAY_SIZE(edp_pwm_gpios)); : struct lb_gpio backlight_gpios[] = { : {GPIO_AP_EDP_BKLTEN.id, ACTIVE_HIGH, -1, "backlight enable"}, : }; Use a single array.
File src/mainboard/google/rauru/devicetree.cb:
https://review.coreboot.org/c/coreboot/+/85951/comment/7f335bde_3aa72ace?usp... : PS2, Line 12: Panel PANEL
File src/mainboard/google/rauru/panel.c:
https://review.coreboot.org/c/coreboot/+/85951/comment/a823755e_c9025367?usp... : PS2, Line 39: Panel PANEL
File src/mainboard/google/rauru/panel_navi.c:
PS2: Rename to panel_oled.c, and rename `get_navi_description` to `get_oled_description`.
Alternatively, I'm fine with merging the content into panel.c. @yidilin@google.com?
https://review.coreboot.org/c/coreboot/+/85951/comment/bde7c542_f37fc1b7?usp... : PS2, Line 15: struct panel_description *get_navi_description(void); Move to panel.h.