Attention is currently required from: Andrey Petrov, Arthur Heymans, Nick Vaccaro, Subrata Banik, Yu-Ping Wu.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/77796?usp=email )
Change subject: {commonlib, libpayload}: Add "is_external display" in coreboot table ......................................................................
Patch Set 2:
(2 comments)
File payloads/libpayload/include/coreboot_tables.h:
https://review.coreboot.org/c/coreboot/+/77796/comment/877fd932_d491276a : PS2, Line 241: u8 is_external_display; Let's make this a `flags` field and define is_external_display as bit 0.
File src/drivers/intel/fsp2_0/graphics.c:
https://review.coreboot.org/c/coreboot/+/77796/comment/de74d7ba_eb853840 : PS2, Line 126: framebuffer_bar As function that's called `report_external_display()` should return whether the external display is on without requiring the caller to check any extra hidden conditions. If you need to check if the framebuffer is set (because as I understood it your function only checks whether the eDP display is *disabled*, right?), then either nyou need to check for that inside the function, or if that's not possible you should rename the function that explains exactly what it does (e.g. flip the result around, call it `edp_display_enabled()`, and then write this as `.is_external_display = framebuffer_bar && !edp_display_enabled()`).