Felix Held has submitted this change and it was merged. ( https://review.coreboot.org/c/coreboot/+/33634 )
Change subject: cpu/amd: use ALIGN_UP instead of ALIGN for better readability ......................................................................
cpu/amd: use ALIGN_UP instead of ALIGN for better readability
Change-Id: Icef97ea764567a311b4cd63b65ad584ed0360152 Signed-off-by: Felix Held felix-coreboot@felixheld.de Reviewed-on: https://review.coreboot.org/c/coreboot/+/33634 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Paul Menzel paulepanter@users.sourceforge.net Reviewed-by: HAOUAS Elyes ehaouas@noos.fr --- M src/cpu/amd/car/post_cache_as_ram.c 1 file changed, 1 insertion(+), 1 deletion(-)
Approvals: build bot (Jenkins): Verified Paul Menzel: Looks good to me, but someone else must approve HAOUAS Elyes: Looks good to me, approved
diff --git a/src/cpu/amd/car/post_cache_as_ram.c b/src/cpu/amd/car/post_cache_as_ram.c index 18e7542..f49c676 100644 --- a/src/cpu/amd/car/post_cache_as_ram.c +++ b/src/cpu/amd/car/post_cache_as_ram.c @@ -45,7 +45,7 @@ static size_t backup_size(void) { size_t car_size = car_data_size(); - return ALIGN(car_size + 1024, 1024); + return ALIGN_UP(car_size + 1024, 1024); }
static void memcpy_(void *d, const void *s, size_t len)