Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39511 )
Change subject: util/inteltool: gpio add code for dumping GPIO Community cfg registers
......................................................................
Uploaded patch set 12.
(1 comment)
https://review.coreboot.org/c/coreboot/+/39511/7/util/inteltool/gpio_groups…
File util/inteltool/gpio_groups.c:
https://review.coreboot.org/c/coreboot/+/39511/7/util/inteltool/gpio_groups…
PS7, Line 82: if (community->community_cfg_registers) {
> `_size` should be 0 too, so we don't need this `if`
ACK and done
> Should we give these register prints a heading?
It's directly printed after the GPIO Community heading, that should be just fine:
------- GPIO Community 3 -------
PCR Port ID: 0xac0000
0x0008: 0xffffffff (FAMBAR)
0x000c: 0x00000400 (PADBAR)
0x0010: 0x00041203 (MISCCFG)
0x0020: 0x00000000 (PAD_OWN_GPP_F_0)
0x0024: 0x00000000 (PAD_OWN_GPP_F_1)
0x0028: 0x00000000 (PAD_OWN_GPP_F_2)
0x0030: 0x00000000 (PAD_OWN_GPP_G_0)
0x00a0: 0x00000000 (PADCFGLOCK_GPP_F)
0x00a4: 0x00000000 (PADCFGLOCKTX_GPP_F)
0x00a8: 0x00000000 (PADCFGLOCK_GPP_G)
0x00ac: 0x00000000 (PADCFGLOCKTX_GPP_G)
0x00d0: 0x00000000 (HOSTSW_OWN_GPP_F)
0x00d4: 0x00000000 (HOSTSW_OWN_GPP_G)
--
To view, visit https://review.coreboot.org/c/coreboot/+/39511
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I493584e74293d5eb15780f781cb69159bbf5383b
Gerrit-Change-Number: 39511
Gerrit-PatchSet: 12
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:55:33 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Hello build bot (Jenkins), Patrick Georgi, Patrick Rudolph, Paul Menzel, Stefan Reinauer, Angel Pons, Mimoja, Aaron Durbin, Nico Huber, Maxim Polyakov, Idwer Vollering, Christian Walter, HAOUAS Elyes, Felix Held,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/39511
to look at the new patch set (#12).
Change subject: util/inteltool: gpio add code for dumping GPIO Community cfg registers
......................................................................
util/inteltool: gpio add code for dumping GPIO Community cfg registers
This adds the code for dumping GPIO Community config registers, which
include Pad Ownership and some other settings.
Change-Id: I493584e74293d5eb15780f781cb69159bbf5383b
Signed-off-by: Michael Niewöhner <foss(a)mniewoehner.de>
---
M util/inteltool/gpio_groups.c
M util/inteltool/gpio_names/gpio_groups.h
2 files changed, 16 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/11/39511/12
--
To view, visit https://review.coreboot.org/c/coreboot/+/39511
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I493584e74293d5eb15780f781cb69159bbf5383b
Gerrit-Change-Number: 39511
Gerrit-PatchSet: 12
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39638 )
Change subject: drivers/intel/gma: hook up GMA for Skylake+
......................................................................
Patch Set 5:
(1 comment)
https://review.coreboot.org/c/coreboot/+/39638/5/src/soc/intel/skylake/acpi…
File src/soc/intel/skylake/acpi/pch.asl:
https://review.coreboot.org/c/coreboot/+/39638/5/src/soc/intel/skylake/acpi…
PS5, Line 33: #include <drivers/intel/gma/acpi/new-pch.asl>
This is all that should be needed after a reset (ACPI wise).
--
To view, visit https://review.coreboot.org/c/coreboot/+/39638
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5c2f0e8fe1ef91334d494c8a8605dd46cda80e3d
Gerrit-Change-Number: 39638
Gerrit-PatchSet: 5
Gerrit-Owner: Benjamin Doron <benjamin.doron00(a)gmail.com>
Gerrit-Reviewer: Benjamin Doron <benjamin.doron00(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:54:49 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39512 )
Change subject: util/inteltool: gpio: add Sunrise Point GPIO Community config registers
......................................................................
Uploaded patch set 13.
(4 comments)
https://review.coreboot.org/c/coreboot/+/39512/12/util/inteltool/gpio_names…
File util/inteltool/gpio_names/sunrise.h:
https://review.coreboot.org/c/coreboot/+/39512/12/util/inteltool/gpio_names…
PS12, Line 64: };
> it's still exactly the same as the non-LP version, or did I miss something?
Done
https://review.coreboot.org/c/coreboot/+/39512/12/util/inteltool/gpio_names…
PS12, Line 84: 0x013
> unlikely
Done
https://review.coreboot.org/c/coreboot/+/39512/12/util/inteltool/gpio_names…
PS12, Line 209: 0x013
> 0x010?
ugh wtf. yes, ofc
https://review.coreboot.org/c/coreboot/+/39512/12/util/inteltool/gpio_names…
PS12, Line 261: 0x013
> eh, you know what I mean
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/39512
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I1ea094878252925f01bea80cc8cf60daf4491061
Gerrit-Change-Number: 39512
Gerrit-PatchSet: 13
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:50:52 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Hello build bot (Jenkins), Patrick Georgi, Patrick Rudolph, Paul Menzel, Stefan Reinauer, Angel Pons, Mimoja, Aaron Durbin, Nico Huber, Maxim Polyakov, Idwer Vollering, Christian Walter, HAOUAS Elyes, Felix Held,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/39512
to look at the new patch set (#13).
Change subject: util/inteltool: gpio: add Sunrise Point GPIO Community config registers
......................................................................
util/inteltool: gpio: add Sunrise Point GPIO Community config registers
This adds the Sunrise Point GPIO Community config registers from
doc#332691-003EN, doc#334659-005 and doc#332996-002EN.
Change-Id: I1ea094878252925f01bea80cc8cf60daf4491061
Signed-off-by: Michael Niewöhner <foss(a)mniewoehner.de>
---
M util/inteltool/gpio_names/sunrise.h
1 file changed, 298 insertions(+), 29 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/12/39512/13
--
To view, visit https://review.coreboot.org/c/coreboot/+/39512
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I1ea094878252925f01bea80cc8cf60daf4491061
Gerrit-Change-Number: 39512
Gerrit-PatchSet: 13
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39724 )
Change subject: util/inteltool: spi: adapt naming scheme
......................................................................
Patch Set 2:
(2 comments)
https://review.coreboot.org/c/coreboot/+/39724/2/util/inteltool/spi.c
File util/inteltool/spi.c:
https://review.coreboot.org/c/coreboot/+/39724/2/util/inteltool/spi.c@226
PS2, Line 226: size
> `registers_size` sounds like a bit-width of something. […]
well... then we should rename ARRAY_SIZE, too 😄
https://review.coreboot.org/c/coreboot/+/39724/2/util/inteltool/spi.c@227
PS2, Line 227: size_t rcba_size = 0x4000;
> Can we make this a constant while we are at it?
this gets dropped anyway in the follow-up
--
To view, visit https://review.coreboot.org/c/coreboot/+/39724
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I53d48633034ac1a01df495f66ee3f5f39d584d05
Gerrit-Change-Number: 39724
Gerrit-PatchSet: 2
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:46:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39565 )
Change subject: util/inteltool: spi: add code for dumping config registers
......................................................................
Patch Set 10:
(1 comment)
https://review.coreboot.org/c/coreboot/+/39565/6/util/inteltool/spi.c
File util/inteltool/spi.c:
https://review.coreboot.org/c/coreboot/+/39565/6/util/inteltool/spi.c@439
PS6, Line 439: pci_free_dev(spi);
> I suppose this was missing in the previous patch?
yup
--
To view, visit https://review.coreboot.org/c/coreboot/+/39565
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibcf6b41ea6eb3fc654872c60fb4298b65ea95932
Gerrit-Change-Number: 39565
Gerrit-PatchSet: 10
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:44:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39566 )
Change subject: util/inteltool: spi: add Sunrise Point config registers
......................................................................
Uploaded patch set 11: New patch set was added with same tree, parent, and commit message as Patch Set 10.
--
To view, visit https://review.coreboot.org/c/coreboot/+/39566
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iee73be6118b7e5f0f1067ef677173c6bd776e7f9
Gerrit-Change-Number: 39566
Gerrit-PatchSet: 11
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 21 Mar 2020 18:44:30 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Hello Felix Singer, build bot (Jenkins), Patrick Georgi, Patrick Rudolph, Paul Menzel, Stefan Reinauer, Angel Pons, Mimoja, Aaron Durbin, Nico Huber, Maxim Polyakov, Idwer Vollering, Christian Walter, HAOUAS Elyes, Felix Held,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/39566
to look at the new patch set (#11).
Change subject: util/inteltool: spi: add Sunrise Point config registers
......................................................................
util/inteltool: spi: add Sunrise Point config registers
This adds the Sunrise Point SPI config registers from doc#332691-003EN.
Change-Id: Iee73be6118b7e5f0f1067ef677173c6bd776e7f9
Signed-off-by: Michael Niewöhner <foss(a)mniewoehner.de>
---
M util/inteltool/spi.c
1 file changed, 8 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/66/39566/11
--
To view, visit https://review.coreboot.org/c/coreboot/+/39566
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iee73be6118b7e5f0f1067ef677173c6bd776e7f9
Gerrit-Change-Number: 39566
Gerrit-PatchSet: 11
Gerrit-Owner: Michael Niewöhner
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Mimoja <coreboot(a)mimoja.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset