Attention is currently required from: Felix Singer.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/55866 )
Change subject: util: Name udev-rules file accordingly
......................................................................
Patch Set 4:
(2 comments)
Commit Message:
https://review.coreboot.org/c/flashrom/+/55866/comment/ea38a1fa_9090a26a
PS1, Line 9: Rename `z60_flashrom.rules` to `flashrom_udev.rules`.
> As upstream systemd/udev uses ordering, I think that is the way to do it.
What's the correct number and why? If there is a single correct number
or it is up to every program to decide, patches are welcome.
Commit Message:
https://review.coreboot.org/c/flashrom/+/55866/comment/ca2a9938_2ce83cbe
PS4, Line 7: accordingly
> Just saw this now. This is missing something. […]
According to what it is: a udev-rules file. Beside the file extension,
the old name gave no hint to its purpose. I guess the new name is not
perfect either. We can still change it.
The z60 prefix was just very irritating. Maybe I should have asked,
what does it mean?
--
To view, visit https://review.coreboot.org/c/flashrom/+/55866
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I1e7918d3121d89d3c388745e433a3a413eac0e21
Gerrit-Change-Number: 55866
Gerrit-PatchSet: 4
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Uwe Hermann <uwe(a)hermann-uwe.de>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Comment-Date: Sat, 03 Jul 2021 10:18:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Singer <felixsinger(a)posteo.net>
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: comment
Attention is currently required from: Edward O'Callaghan.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/56028 )
Change subject: flashrom.8: Add Anastasia to authors list
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
Angel and Nico are not in this list??
--
To view, visit https://review.coreboot.org/c/flashrom/+/56028
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib1ede56e2446833f7dc9acacdb0f26ed822bc7a4
Gerrit-Change-Number: 56028
Gerrit-PatchSet: 1
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Sat, 03 Jul 2021 01:05:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Michał Żygowski, Paul Menzel.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/55578 )
Change subject: Add Tiger Lake U Premium support
......................................................................
Patch Set 5: Code-Review+1
(4 comments)
Patchset:
PS5:
Thanks for also looking at the registers. I guess we could add a TODO
for earlier chipsets that support eSPI. Currently we might add LPC/FWH
buses by accident for them. For these transition chipsets, we should
probably check a strap if it's using eSPI or LPC.
File chipset_enable.c:
https://review.coreboot.org/c/flashrom/+/55578/comment/bd00365c_e3ce128c
PS3, Line 659: { "eSPI", BUS_LPC | BUS_FWH } };
> Not sure about this one, whether eSPI should be mapped to LPC and FWH
No, it shouldn't. We use these flags to decide which chips to probe
for, and I guess even if an eSPI chip might work similarly (IIRC,
LPC/FWH just had memory mapped registers) it would be a different
set of chips (does anybody make/use eSPI NOR flash?).
File ich_descriptors.c:
https://review.coreboot.org/c/flashrom/+/55578/comment/72719007_5b975178
PS5, Line 278: return "reserved";
I'd suggest "unknown" if we don't want to add a table above. Note, that
the call to this function for `freq_read` is spurious since, I guess,
Cannon Point and should probably be guarded.
https://review.coreboot.org/c/flashrom/+/55578/comment/836940d1_92c2adbf
PS5, Line 967: return CHIPSET_500_SERIES_TIGER_POINT;
As suggested somewhere else, I would make this the new fall-back, i.e.
if (ICCRIBA == 0x34)
return CANNON_POINT;
if (ICCRIBA != 0x11)
msg_pwarn(...);
return TIGER_POINT;
That should make things more future-proof.
Calling it ICCRIBA for Tiger Point is wrong ofc. but that's just cosmetics.
We could add another union in `ich_descriptors.h`.
--
To view, visit https://review.coreboot.org/c/flashrom/+/55578
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I28f3b6fe9f8ce9e976a6808683f46b6f4ec72bdd
Gerrit-Change-Number: 55578
Gerrit-PatchSet: 5
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Fri, 02 Jul 2021 15:03:32 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-MessageType: comment
Attention is currently required from: Thomas Heijligen, Anastasia Klimchuk.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/55999 )
Change subject: layout: Turn overlap debug message into warning
......................................................................
Patch Set 1:
(1 comment)
File layout.c:
https://review.coreboot.org/c/flashrom/+/55999/comment/5d6f893b_23ec4ed8
PS1, Line 269: warn
> It's certainly unexpected. The only place where this is currently called from treats this as an error.
That's it. And the only case when the warnings would be spurious would be
when the caller wanted to handle the overlapping somehow explicitly. But
then it would have to walk the layout again to find the details. Which
makes this function less useful for such a case, I guess.
--
To view, visit https://review.coreboot.org/c/flashrom/+/55999
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ie969e0538d302ccd58d3fec3921265ed3621eaa5
Gerrit-Change-Number: 55999
Gerrit-PatchSet: 1
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Fri, 02 Jul 2021 12:11:46 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Michał Żygowski, Angel Pons, Michael Niewöhner.
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/55714
to look at the new patch set (#5).
Change subject: acpi_ec: Implement basic ACPI embedded controller API
......................................................................
acpi_ec: Implement basic ACPI embedded controller API
Implement basic functions to read/write EC registers and send standard
ACPI EC commands. Those may prove useful in possible future
implementations of embedded controllers in flashrom and are required
to support EC firmware flashing on Tuxedo laptops.
Signed-off-by: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Signed-off-by: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Change-Id: Ie3bae8d81c80ae2f286b619e974869e3f2f4545d
---
M Makefile
A acpi_ec.c
A acpi_ec.h
3 files changed, 160 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/14/55714/5
--
To view, visit https://review.coreboot.org/c/flashrom/+/55714
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ie3bae8d81c80ae2f286b619e974869e3f2f4545d
Gerrit-Change-Number: 55714
Gerrit-PatchSet: 5
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: Nico Huber, Edward O'Callaghan, Anastasia Klimchuk.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/54890 )
Change subject: programmer: Introduce default shutdown function
......................................................................
Patch Set 5:
(1 comment)
File flashrom.c:
https://review.coreboot.org/c/flashrom/+/54890/comment/73d560f8_6da467c4
PS5, Line 104: function;
> `shutdown_fn[shutdown_fn_count]. […]
I'd much prefer to return an error if one calls `register_shutdown()` with a null function pointer.
--
To view, visit https://review.coreboot.org/c/flashrom/+/54890
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I8b20717ba549e12edffbc5d1643ff064a4f0c517
Gerrit-Change-Number: 54890
Gerrit-PatchSet: 5
Gerrit-Owner: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Fri, 02 Jul 2021 11:21:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-MessageType: comment