Aaron Durbin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/42832 )
Change subject: mb/google/zork: Add Bluetooth reset gpios to devicetree ......................................................................
Patch Set 13:
(2 comments)
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... File src/mainboard/google/zork/variants/baseboard/ramstage_common.c:
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... PS13, Line 115: xhci0_bt_cfg->reset_gpio.pin_count = 0; This whole sequence could have used a helper function that took a path and string name as to not duplicate the logic too much. We're also bailing early above which wouldn't fix up the latter one below.
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... PS13, Line 118: if (CONFIG(BOARD_GOOGLE_BASEBOARD_DALBOZ)) There is already a dalboz check below. This is redundant.