Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/75591?usp=email )
Change subject: soc/amd/picasso/acpi: rename sb_fch.asl to mmio.asl ......................................................................
soc/amd/picasso/acpi: rename sb_fch.asl to mmio.asl
This file only contain the ACPI code describing the MMIO devices in the FCH, so rename it to mmio.asl. This also brings the Picasso ACPI code a bit more in line with the ACPI code of the newer SoCs.
Signed-off-by: Felix Held felix-coreboot@felixheld.de Change-Id: I64490ba8e34ae1fbe6aea1ab6496b5b04ac4d0aa Reviewed-on: https://review.coreboot.org/c/coreboot/+/75591 Reviewed-by: Raul Rangel rrangel@chromium.org Reviewed-by: Matt DeVillier matt.devillier@amd.corp-partner.google.com Tested-by: build bot (Jenkins) no-reply@coreboot.org --- R src/soc/amd/picasso/acpi/mmio.asl M src/soc/amd/picasso/acpi/soc.asl 2 files changed, 2 insertions(+), 2 deletions(-)
Approvals: Matt DeVillier: Looks good to me, approved Raul Rangel: Looks good to me, approved build bot (Jenkins): Verified
diff --git a/src/soc/amd/picasso/acpi/sb_fch.asl b/src/soc/amd/picasso/acpi/mmio.asl similarity index 100% rename from src/soc/amd/picasso/acpi/sb_fch.asl rename to src/soc/amd/picasso/acpi/mmio.asl diff --git a/src/soc/amd/picasso/acpi/soc.asl b/src/soc/amd/picasso/acpi/soc.asl index 0b520e4..a958570 100644 --- a/src/soc/amd/picasso/acpi/soc.asl +++ b/src/soc/amd/picasso/acpi/soc.asl @@ -19,8 +19,8 @@ /* Describe PCI INT[A-H] for the Southbridge */ #include <soc/amd/common/acpi/pci_int.asl>
-/* Describe the devices in the Southbridge */ -#include "sb_fch.asl" +/* Describe the MMIO devices in the FCH */ +#include "mmio.asl"
/* Add GPIO library */ #include <soc/amd/common/acpi/gpio_bank_lib.asl>