Shelley Chen has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/44006 )
Change subject: mrc_cache: mrc_cache fetch functions to support non-x86 platforms
......................................................................
Patch Set 7:
(1 comment)
https://review.coreboot.org/c/coreboot/+/44006/7/src/drivers/intel/fsp1_1/ro...
File src/drivers/intel/fsp1_1/romstage.c:
https://review.coreboot.org/c/coreboot/+/44006/7/src/drivers/intel/fsp1_1/ro...
PS7, Line 53: (CONFIG(CACHE_MRC_SETTINGS)
This check was located earlier. […]
So I tried to keep the assignment and the check in the same line as before, but coreboot has some pre-commit checks that prevent that type of code from going in (for good reason, since it's hard to read). The logic should be the same. We just split it into two lines now (one for the assignment and one for the condition). We need the assignment though, unlike the previous mrc_cache_get_current where we could just check the return value.
--
To view, visit
https://review.coreboot.org/c/coreboot/+/44006
To unsubscribe, or for help writing mail filters, visit
https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I259dd4f550719d821bbafa2d445cbae6ea22e988
Gerrit-Change-Number: 44006
Gerrit-PatchSet: 7
Gerrit-Owner: Shelley Chen
shchen@google.com
Gerrit-Reviewer: Andrey Petrov
andrey.petrov@gmail.com
Gerrit-Reviewer: Angel Pons
th3fanbus@gmail.com
Gerrit-Reviewer: Damien Zammit
Gerrit-Reviewer: Furquan Shaikh
furquan@google.com
Gerrit-Reviewer: Huang Jin
huang.jin@intel.com
Gerrit-Reviewer: Julius Werner
jwerner@chromium.org
Gerrit-Reviewer: Karthik Ramasubramanian
kramasub@google.com
Gerrit-Reviewer: Lee Leahy
leroy.p.leahy@intel.com
Gerrit-Reviewer: Patrick Rudolph
siro@das-labor.org
Gerrit-Reviewer: Tim Wawrzynczak
twawrzynczak@chromium.org
Gerrit-Reviewer: Yu-Ping Wu
yupingso@google.com
Gerrit-Reviewer: build bot (Jenkins)
no-reply@coreboot.org
Gerrit-Comment-Date: Wed, 29 Jul 2020 17:43:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons
th3fanbus@gmail.com
Gerrit-MessageType: comment