Aaron Durbin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/32770 )
Change subject: coreboot: add post code for failure to load next stage ......................................................................
Patch Set 1:
(1 comment)
Patch Set 1:
Patch Set 1:
Define a big die_notify within wilco ec to add post code instead of touch all the pieces in coreboot? Though the compare string and then send out different post code will not be pretty.
Nearly all the die() calls within coreboot do not update the post code, so the actual failure can only be inferred from the operation attempted (e.g. POST_FSP_MEMORY_EXIT would imply a memory failure). This change stack adds new explicit post codes on calls to die() that could possibly happen due to a hardware failure.
I think what Lance was referring to was to add a helper function/macro that does keeps the open coding from occurring at the call sites. e.g. die_with_postcode(int postcode, const char *msg); or something like that.
https://review.coreboot.org/#/c/32770/1/src/include/console/post_codes.h File src/include/console/post_codes.h:
https://review.coreboot.org/#/c/32770/1/src/include/console/post_codes.h@326 PS1, Line 326: xE hex constants seem to be lower case in this file (aside from AGESA ones below). Please be consistent.