Raul Rangel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45340 )
Change subject: soc/amd/picasso: Generate ACPI pstate and cstate objects in cb ......................................................................
Patch Set 22:
(4 comments)
https://review.coreboot.org/c/coreboot/+/45340/19/src/soc/amd/picasso/acpi.c File src/soc/amd/picasso/acpi.c:
https://review.coreboot.org/c/coreboot/+/45340/19/src/soc/amd/picasso/acpi.c... PS19, Line 186: 200 * core_freq_mul) / (core_freq_div
In order to do this I would have to use floating arithmetic. […]
How about: (PSTATE_DEF_LO_CORE_FREQ_BASE * core_freq_mul * 8) / core_freq_div;
https://review.coreboot.org/c/coreboot/+/45340/22/src/soc/amd/picasso/acpi.c File src/soc/amd/picasso/acpi.c:
https://review.coreboot.org/c/coreboot/+/45340/22/src/soc/amd/picasso/acpi.c... PS22, Line 184: core_freq Can you just return 0?
https://review.coreboot.org/c/coreboot/+/45340/22/src/soc/amd/picasso/acpi.c... PS22, Line 234: current_value Can you rename this to current_value_amps or something like it. This way it's easier to make sure all the units are correct.
https://review.coreboot.org/c/coreboot/+/45340/22/src/soc/amd/picasso/acpi.c... PS22, Line 305: static Does this need to be static?