Sridhar Siricilla has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35226 )
Change subject: src/soc/intel/common/block/cse: Make hfsts1 common & add helper functions ......................................................................
Patch Set 17:
(2 comments)
https://review.coreboot.org/c/coreboot/+/35226/14/src/soc/intel/common/block... File src/soc/intel/common/block/cse/cse.c:
https://review.coreboot.org/c/coreboot/+/35226/14/src/soc/intel/common/block... PS14, Line 282: csr |= CSR_READY;
For readability sake, the operations are separated into two statements.
Done
https://review.coreboot.org/c/coreboot/+/35226/17/src/soc/intel/common/block... File src/soc/intel/common/block/cse/cse.c:
https://review.coreboot.org/c/coreboot/+/35226/17/src/soc/intel/common/block... PS17, Line 525: csr = read_host_csr(); : csr |= (CSR_RESET | CSR_IG); : write_host_csr(csr);
can we create a static helper function ?
The function name itself indicates triggering reset. So, I think static helper function is not required. Thanks