Attention is currently required from: Hung-Te Lin, Paul Menzel, Yidi Lin, Yu-Ping Wu.
Jarried Lin has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85188?usp=email )
Change subject: soc/mediatek/mt8196: Add MMinfra driver support ......................................................................
Patch Set 23:
(5 comments)
File src/soc/mediatek/mt8196/bootblock.c:
https://review.coreboot.org/c/coreboot/+/85188/comment/4792f99c_c459adea?usp... : PS5, Line 19: mm_pre_init
Why is this called `pre_init`? This only registers callbacks for 3 IDs. […]
Done
File src/soc/mediatek/mt8196/include/soc/mminfra.h:
https://review.coreboot.org/c/coreboot/+/85188/comment/67990d20_0d6b510f?usp... : PS5, Line 33: mm
mminfra
Done
File src/soc/mediatek/mt8196/mminfra_pd.c:
PS5:
If there's no other `mminfra_*.c` files, can we rename this to `mminfra. […]
Done
https://review.coreboot.org/c/coreboot/+/85188/comment/8d3e4e4a_295d76a2?usp... : PS5, Line 35: while (read32p(MMINFRA_MM0_GALS_PROT_TX_RDY) != 0xff) : ;
You can implement a common function and pass register address and expected value to that function. […]
Done
https://review.coreboot.org/c/coreboot/+/85188/comment/4c7e933b_7d20bf30?usp... : PS5, Line 66: static int pd_mm_infra_ao_pre_on(void) : { : return 0; : } : : static int pd_mm_infra_ao_post_on(void) : { : return 0; : } : : static int pd_mm_infra_ao_pre_off(void) : { : return 0; : } : : static int pd_mm_infra_ao_post_off(void) : { : return 0; : }
Just remove if not used. `mtcmos_callback` will check if the callback is existed.
Done