Attention is currently required from: Nico Huber, Diana Zigterman, Edward O'Callaghan, Anastasia Klimchuk, Karthik Ramasubramanian.
Robert Zieba has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62909 )
Change subject: raiden_debug_spi: Add more informative error message when WP is enabled
......................................................................
Patch Set 4:
(4 comments)
File raiden_debug_spi.c:
https://review.coreboot.org/c/flashrom/+/62909/comment/d9a9670f_dcd0ad73
PS3, Line 987:
> trailing space
Done
https://review.coreboot.org/c/flashrom/+/62909/comment/aae994af_9988af5c
PS3, Line 987: /* Check if we received an error from the device. An error will have no response
: data, just the packet_id and status_code. */
> While not expliticitly mentioned, even the Linux kernel accepts the […]
Done
https://review.coreboot.org/c/flashrom/+/62909/comment/96682e8e_d7f658b6
PS3, Line 989:
> trailing space
Done
https://review.coreboot.org/c/flashrom/+/62909/comment/bb54fd2d_d282e4cb
PS3, Line 990: sizeof(struct usb_spi_response_v2) - USB_SPI_PAYLOAD_SIZE_V2_RESPONSE &&
: rsp_config.packet_v2.rsp_start.status_code != USB_SPI_SUCCESS) {
> Could you please add one more tab before these two lines? It would be easier to visually distinguish […]
Done
--
To view, visit https://review.coreboot.org/c/flashrom/+/62909
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib1e8383baa9c3ea41ab1079af12e3dc8cdff90ae
Gerrit-Change-Number: 62909
Gerrit-PatchSet: 4
Gerrit-Owner: Robert Zieba <robertzieba(a)google.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Eric Peers <epeers(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rob Barnes <robbarnes(a)google.com>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Wed, 13 Apr 2022 21:16:12 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Robert Zieba, Diana Zigterman, Edward O'Callaghan, Anastasia Klimchuk, Karthik Ramasubramanian.
Hello build bot (Jenkins), Nico Huber, Diana Zigterman, Jon Murphy, Edward O'Callaghan, Anastasia Klimchuk, Karthik Ramasubramanian,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/62909
to look at the new patch set (#4).
Change subject: raiden_debug_spi: Add more informative error message when WP is enabled
......................................................................
raiden_debug_spi: Add more informative error message when WP is enabled
Current error messages are not very helpful when attempting to flash a
target that has WP enabled. This change checks for the USB_SPI_DISABLED
error that occurs in this case and gives a more informative error
message.
BUG=b:210645611
TEST=Tested with WP enabled and disable to verify that error message is
displayed properly
Signed-off-by: Robert Zieba <robertzieba(a)google.com>
Change-Id: Ib1e8383baa9c3ea41ab1079af12e3dc8cdff90ae
---
M raiden_debug_spi.c
1 file changed, 17 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/09/62909/4
--
To view, visit https://review.coreboot.org/c/flashrom/+/62909
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib1e8383baa9c3ea41ab1079af12e3dc8cdff90ae
Gerrit-Change-Number: 62909
Gerrit-PatchSet: 4
Gerrit-Owner: Robert Zieba <robertzieba(a)google.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Eric Peers <epeers(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rob Barnes <robbarnes(a)google.com>
Gerrit-Attention: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Idwer Vollering, Angel Pons.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/63612 )
Change subject: platform.h: rename swapX to ___swapX
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> Hmmm, are names starting with `___` considered to start with `__`?
They might mean `__[a-zA-Z]` and not `___`...
--
To view, visit https://review.coreboot.org/c/flashrom/+/63612
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I04d73967f694939c1127f48df8645a10e9dd66f3
Gerrit-Change-Number: 63612
Gerrit-PatchSet: 1
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 13 Apr 2022 19:02:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Thomas Heijligen <src(a)posteo.de>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Robert Zieba, Diana Zigterman, Edward O'Callaghan, Anastasia Klimchuk, Karthik Ramasubramanian.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62909 )
Change subject: raiden_debug_spi: Add more informative error message when WP is enabled
......................................................................
Patch Set 3:
(1 comment)
File raiden_debug_spi.c:
https://review.coreboot.org/c/flashrom/+/62909/comment/f30feb20_bb78e2a6
PS3, Line 987: /* Check if we received an error from the device. An error will have no response
: data, just the packet_id and status_code. */
> We follow coding style https://www.flashrom. […]
While not expliticitly mentioned, even the Linux kernel accepts the
condensed style, as do folks in coreboot. However, as the code around
uses the longer style, I guess that's preferred here.
--
To view, visit https://review.coreboot.org/c/flashrom/+/62909
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib1e8383baa9c3ea41ab1079af12e3dc8cdff90ae
Gerrit-Change-Number: 62909
Gerrit-PatchSet: 3
Gerrit-Owner: Robert Zieba <robertzieba(a)google.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Eric Peers <epeers(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Rob Barnes <robbarnes(a)google.com>
Gerrit-Attention: Robert Zieba <robertzieba(a)google.com>
Gerrit-Attention: Diana Zigterman <dzigterman(a)google.com>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Wed, 13 Apr 2022 17:37:59 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Thomas Heijligen, Edward O'Callaghan, Tom Hughes.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/63001 )
Change subject: programmer: Use C linkage when compiling with C++
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> flashrom is entirely written in C and should only be compiled with a proper C compiler. […]
I agree with this sentiment. However, for every change there's a reason, we
should hear it first. Looking downstream, there's a Chrome EC driver that wants
to make use of some C++ API it seems. Any plan to upstream that?
--
To view, visit https://review.coreboot.org/c/flashrom/+/63001
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I7e12ead58dee07313d756f1afcc687ba12b6392b
Gerrit-Change-Number: 63001
Gerrit-PatchSet: 1
Gerrit-Owner: Tom Hughes <tomhughes(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Tom Hughes <tomhughes(a)chromium.org>
Gerrit-Comment-Date: Wed, 13 Apr 2022 17:25:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: comment
Attention is currently required from: Subrata Banik, Angel Pons, Anastasia Klimchuk.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62894 )
Change subject: ichspi: Rename HSFC FDBC offset macros
......................................................................
Patch Set 8:
(1 comment)
Commit Message:
https://review.coreboot.org/c/flashrom/+/62894/comment/c926c1a4_8e022d39
PS6, Line 10: during the data portion of the SPI cycle.
> My understanding is that renaming is needed for the next patch CB:62892 which introduces `HSFC_FDBC(n)`. Subrata please correct me if I am wrong?
Only because the next patch provokes a name conflict. And only
for `HSFC_FDBC -> HSFC_FDBC_MASK`, and not for the `_OFF` macro.
`HSFC_FDBC_OFF` is the correct name anyway, and probably only
changed to keep it pprint_reg() compatible. But then it's incon-
sistent with all the other `_OFF` macro names... It seems the only
winning move is not to play. How about naming the new macro diffe-
rently, e.g. `HSFC_FDBC_VAL(n)`?
--
To view, visit https://review.coreboot.org/c/flashrom/+/62894
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ia0ae9a586b5c12f0229334898426175ec246a70c
Gerrit-Change-Number: 62894
Gerrit-PatchSet: 8
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Subrata Banik <subi.banik(a)gmail.com>
Gerrit-Attention: Subrata Banik <subi.banik(a)gmail.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Wed, 13 Apr 2022 17:16:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Subrata Banik, Edward O'Callaghan, Angel Pons, Anastasia Klimchuk.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62868 )
Change subject: ichspi: Introduce HSFC CYCLE READ/WRITE/ERASE macros
......................................................................
Patch Set 15:
(1 comment)
Patchset:
PS14:
> > I am thinking, there is a chain of changes with the macros, starting from CB:62888 and until this […]
See `-E` flag to GCC. If you run `make` it prints the `gcc` lines to compile
individual files, you can exchange `-o ... -c` with `-E`.
However, as flashrom builds are reproducible, you can also just compare the
final binary, e.g. `cmp flashrom flashrom.old`.
--
To view, visit https://review.coreboot.org/c/flashrom/+/62868
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I3ea74b668e5f8d8e4b3da2a8ad8b81f1813e1e80
Gerrit-Change-Number: 62868
Gerrit-PatchSet: 15
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Subrata Banik <subi.banik(a)gmail.com>
Gerrit-Attention: Subrata Banik <subi.banik(a)gmail.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Wed, 13 Apr 2022 17:07:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Idwer Vollering, Angel Pons.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/63612 )
Change subject: platform.h: rename swapX to ___swapX
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> Hmmm, I remember reading something about names starting with underscores being special in the C spec […]
'_' and '__' are reserved.
* naming starting with _ for the language entities, which includes the standard library
* naming starting with __ for the compiler internals
C Standard Section 7.1.3
--
To view, visit https://review.coreboot.org/c/flashrom/+/63612
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I04d73967f694939c1127f48df8645a10e9dd66f3
Gerrit-Change-Number: 63612
Gerrit-PatchSet: 1
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 13 Apr 2022 13:43:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment