Attention is currently required from: Brian Norris, Peter Marheine, Thomas Heijligen.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/81545?usp=email )
Change subject: udelay: only use OS time for delays, except on DOS ......................................................................
Patch Set 7:
(5 comments)
Commit Message:
https://review.coreboot.org/c/flashrom/+/81545/comment/ccd19393_e76a5d95 : PS7, Line 10: ) you can also add the link to archive (keep the title) https://mail.coreboot.org/hyperkitty/list/flashrom@flashrom.org/thread/HFH6U...
File include/programmer.h:
https://review.coreboot.org/c/flashrom/+/81545/comment/9d01fccc_bfddca33 : PS7, Line 222: void myusec_delay(unsigned int usecs); I am wondering, why `myusec_delay` was here in the first place? It wasn't used anywhere outside udelay.c.
File tests/udelay.c:
https://review.coreboot.org/c/flashrom/+/81545/comment/ebf04ffe_2553bf5c : PS7, Line 47: default_delay(100); I thought for a moment we can afford a long delay test, for usec = 100001, but I don't know would it be useful test? Maybe it belongs better to a next patch where you can verify nanosleep was called / not called depending on the length of the sleep?
File udelay.c:
https://review.coreboot.org/c/flashrom/+/81545/comment/77dc43b4_fc7866da : PS7, Line 33: #ifdef _POSIX_MONOTONIC_CLOCK : static clockid_t clock_id = CLOCK_MONOTONIC; : #else : static clockid_t clock_id = CLOCK_REALTIME; : #endif This is only used inside `clock_usec_delay` now, can it be locally defined inside the function? It will be easier to read too.
https://review.coreboot.org/c/flashrom/+/81545/comment/6f8bb5ec_181589c6 : PS7, Line 62: inline For my education, why the function is inline only for this case and not the above?