Attention is currently required from: Brian Norris, Peter Marheine, Thomas Heijligen.
5 comments:
Commit Message:
you can also add the link to archive (keep the title) https://mail.coreboot.org/hyperkitty/list/flashrom@flashrom.org/thread/HFH6UHPAKA4JDL4YKPSQPO72KXSSRGME/
File include/programmer.h:
Patch Set #7, Line 222: void myusec_delay(unsigned int usecs);
I am wondering, why `myusec_delay` was here in the first place? It wasn't used anywhere outside udelay.c.
File tests/udelay.c:
Patch Set #7, Line 47: default_delay(100);
I thought for a moment we can afford a long delay test, for usec = 100001, but I don't know would it be useful test?
Maybe it belongs better to a next patch where you can verify nanosleep was called / not called depending on the length of the sleep?
File udelay.c:
#ifdef _POSIX_MONOTONIC_CLOCK
static clockid_t clock_id = CLOCK_MONOTONIC;
#else
static clockid_t clock_id = CLOCK_REALTIME;
#endif
This is only used inside `clock_usec_delay` now, can it be locally defined inside the function? It will be easier to read too.
Patch Set #7, Line 62: inline
For my education, why the function is inline only for this case and not the above?
To view, visit change 81545. To unsubscribe, or for help writing mail filters, visit settings.