Mike Banon has posted comments on this change. ( https://review.coreboot.org/23260 )
Change subject: edi: Add dummy read to ensure proper detection of ENE chips ......................................................................
Patch Set 6:
(1 comment)
https://review.coreboot.org/#/c/23260/3/edi.c File edi.c:
https://review.coreboot.org/#/c/23260/3/edi.c@166 PS3, Line 166: static void edi_draw_attention(struct flashctx *flash)
I agree with Nico that inlining the function is preferable than coming up with names that aren't exa […]
Theoretically it could be that some future ENE KB's would require more action to draw attention than a single dummy read, so it made sense for me to improve this function instead of inlining it. I have renamed it to "edi_draw_attention" like Nico proposed (I also like this name) and wrote a small comment to clarify whats going on. Hope it looks good now
static void edi_draw_attention(struct flashctx *flash) { unsigned char hwversion;
/* * This dummy read draws the chip's attention * and as result the chip enables its' EDI */ edi_read(flash, ENE_EC_HWVERSION, &hwversion); }