1 comment:
Patch Set #3, Line 166: static void edi_draw_attention(struct flashctx *flash)
I agree with Nico that inlining the function is preferable than coming up with names that aren't exa […]
Theoretically it could be that some future ENE KB's would require more action to draw attention than a single dummy read, so it made sense for me to improve this function instead of inlining it. I have renamed it to "edi_draw_attention" like Nico proposed (I also like this name) and wrote a small comment to clarify whats going on. Hope it looks good now
static void edi_draw_attention(struct flashctx *flash)
{
unsigned char hwversion;
/*
* This dummy read draws the chip's attention
* and as result the chip enables its' EDI
*/
edi_read(flash, ENE_EC_HWVERSION, &hwversion);
}
To view, visit change 23260. To unsubscribe, or for help writing mail filters, visit settings.