Attention is currently required from: Anastasia Klimchuk, Peter Marheine.
Dmitry Zhadinets has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/86921?usp=email )
Change subject: libflashrom: Added API to enumerate supported programmers ......................................................................
Patch Set 2:
(7 comments)
Patchset:
PS1:
At least `list_programmers_linebreak` can be converted to use the new API, so it makes sense to do t […]
If you are about iterator. lets discuss it in the next commit
Commit Message:
https://review.coreboot.org/c/flashrom/+/86921/comment/3d88b9fa_a592b3ab?usp... : PS2, Line 6: : libflashrom: Added API to enumerate supported programmers
Few corrections: […]
Done
File include/libflashrom.h:
https://review.coreboot.org/c/flashrom/+/86921/comment/a4773c9d_9879ee74?usp... : PS2, Line 169: flashrom_supported_programmers
This needs to be added to libflashrom. […]
Done
File include/libflashrom.h:
https://review.coreboot.org/c/flashrom/+/86921/comment/8ab50306_35e32acf?usp... : PS1, Line 166: * @return List of supported programmers, or NULL if an error occurred.
Just to be explicit, this should say that the last entry in the returned list is followed by a NULL.
Done
File tests/libflashrom.c:
https://review.coreboot.org/c/flashrom/+/86921/comment/69b455e4_70880105?usp... : PS1, Line 4: Copyright 2020 Google LLC
That's you are adding a new test, should be your name here
Done
File tests/libflashrom.c:
https://review.coreboot.org/c/flashrom/+/86921/comment/d317f8c4_42a5cf02?usp... : PS2, Line 22: enumerators_test_success
I would rename this to `flashrom_supported_programmers_test_success` to use the same name as the fun […]
Done
https://review.coreboot.org/c/flashrom/+/86921/comment/67d89092_5cae1a6a?usp... : PS2, Line 24: (void) state; /* unused */ : const char** array = flashrom_supported_programmers(); : const char** ptr = array; : assert_non_null(array); : while (*(ptr++)){} : flashrom_data_free(array); : assert_int_not_equal(ptr - array, 0);
This needs a fix for the indentation (use tabs always) […]
Done