Attention is currently required from: Anastasia Klimchuk, Peter Marheine.
7 comments:
Patchset:
At least `list_programmers_linebreak` can be converted to use the new API, so it makes sense to do t […]
If you are about iterator. lets discuss it in the next commit
Commit Message:
libflashrom: Added API to enumerate supported programmers
Few corrections: […]
Done
File include/libflashrom.h:
Patch Set #2, Line 169: flashrom_supported_programmers
This needs to be added to libflashrom. […]
Done
File include/libflashrom.h:
Patch Set #1, Line 166: * @return List of supported programmers, or NULL if an error occurred.
Just to be explicit, this should say that the last entry in the returned list is followed by a NULL.
Done
File tests/libflashrom.c:
Patch Set #1, Line 4: Copyright 2020 Google LLC
That's you are adding a new test, should be your name here
Done
File tests/libflashrom.c:
Patch Set #2, Line 22: enumerators_test_success
I would rename this to `flashrom_supported_programmers_test_success` to use the same name as the fun […]
Done
(void) state; /* unused */
const char** array = flashrom_supported_programmers();
const char** ptr = array;
assert_non_null(array);
while (*(ptr++)){}
flashrom_data_free(array);
assert_int_not_equal(ptr - array, 0);
This needs a fix for the indentation (use tabs always) […]
Done
To view, visit change 86921. To unsubscribe, or for help writing mail filters, visit settings.