Attention is currently required from: Nico Huber, Edward O'Callaghan, Angel Pons, Peter Marheine. Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/56911 )
Change subject: tests: add init_shutdown test for realtek_mst_i2c_spi ......................................................................
Patch Set 3: Code-Review+1
(3 comments)
File tests/init_shutdown.c:
https://review.coreboot.org/c/flashrom/+/56911/comment/8b60edfe_05f27ab9 PS3, Line 234: // Only access to I2C address 0x4a is expected Do we really have one line comments, I am not sure... I thought it is /* */ everywhere?
https://review.coreboot.org/c/flashrom/+/56911/comment/4c72f5ea_251e87c0 PS3, Line 252: else if (sz == 1 || sz == 2) : return sz; : else : return -1; Since you return, else if, and else is not needed
https://review.coreboot.org/c/flashrom/+/56911/comment/36e1264c_f90190d8 PS3, Line 267: io_mock_register(&realtek_mst_io); : run_lifecycle(state, &programmer_realtek_mst_i2c_spi, "bus=254,enter-isp=0"); : io_mock_register(NULL); This is a small thing, but for consistency and readability, if you could add empty lines between io_mock_register and run_lifecycle? (like in the other tests)