Attention is currently required from: Aarya, Anastasia Klimchuk, Edward O'Callaghan.
Peter Marheine has posted comments on this change by Aarya. ( https://review.coreboot.org/c/flashrom/+/83834?usp=email )
Change subject: tree: Retype variable `is_laptop` to enum ......................................................................
Patch Set 3:
(3 comments)
File dmi.c:
https://review.coreboot.org/c/flashrom/+/83834/comment/8fdd8139_95b4149f?usp... : PS3, Line 67: * - 0: in all likelihood not a laptop : * - 1: in all likelihood a laptop : * - 2: chassis-type is not specific enough
This need to be updated (there are no numbers anymore, enum instead)
I'd prefer to move this documentation to the enum definition, too.
File internal.c:
https://review.coreboot.org/c/flashrom/+/83834/comment/573903b4_7cf9f7d2?usp... : PS3, Line 113: if ((is_laptop != YES) || laptop_ok) Original here was `is_laptop == NO`; this would incorrectly assume `UNKNOWN` is not a laptop, which is specifically handled by the branch on line 121.
https://review.coreboot.org/c/flashrom/+/83834/comment/44599618_de335bff?usp... : PS3, Line 230: bcfg.is_laptop == YES
Strictly speaking, the previous code is equivalent to bcfg. […]
The double negative makes it difficult to follow, so I think rewording the comment would help.
``` /* * Disable internal buses if this might be a laptop, unless overridden. */ if (bcfg.is_laptop != NO && !(bcfg.laptop_ok || force_laptop || (not_a_laptop && bcfg.is_laptop == UNKNOWN)) ```