Attention is currently required from: Aarya, Anastasia Klimchuk, Edward O'Callaghan.
3 comments:
File dmi.c:
* - 0: in all likelihood not a laptop
* - 1: in all likelihood a laptop
* - 2: chassis-type is not specific enough
This need to be updated (there are no numbers anymore, enum instead)
I'd prefer to move this documentation to the enum definition, too.
File internal.c:
Patch Set #3, Line 113: if ((is_laptop != YES) || laptop_ok)
Original here was `is_laptop == NO`; this would incorrectly assume `UNKNOWN` is not a laptop, which is specifically handled by the branch on line 121.
Patch Set #3, Line 230: bcfg.is_laptop == YES
Strictly speaking, the previous code is equivalent to bcfg. […]
The double negative makes it difficult to follow, so I think rewording the comment would help.
```
/*
* Disable internal buses if this might be a laptop, unless overridden.
*/
if (bcfg.is_laptop != NO && !(bcfg.laptop_ok || force_laptop || (not_a_laptop && bcfg.is_laptop == UNKNOWN))
```
To view, visit change 83834. To unsubscribe, or for help writing mail filters, visit settings.