Attention is currently required from: Bill XIE, Nikolai Artemiev, Peter Marheine.
Anastasia Klimchuk has posted comments on this change by Bill XIE. ( https://review.coreboot.org/c/flashrom/+/84253?usp=email )
Change subject: ichspi: Probe opcode in POSSIBLE_OPCODES[] as well ......................................................................
Patch Set 5: Code-Review+2
(3 comments)
File ichspi.c:
https://review.coreboot.org/c/flashrom/+/84253/comment/ca73d0b1_ef2bbd2d?usp... : PS1, Line 664: int oppos = 2; // use original JEDEC_BE_D8 offset
I made a separate patch CB:84567 in case it end up being useful. […]
Okay I am closing this thread
https://review.coreboot.org/c/flashrom/+/84253/comment/af921339_559b1464?usp... : PS1, Line 1843: : static bool ich_spi_probe_opcode(const struct flashctx *flash, uint8_t opcode) : { : return find_opcode(curopcodes, opcode) >= 0;
Please show me your elegant solution to program other erasing opcodes on the fly, but not before CB:84567 and CB:84593. ;-)
You win, you are more elegant :) I had in my mind checking inside `ich_spi_probe_opcode` for all erase opcodes, but I was thinking about hardcoded list of (JEDEC_SE, JEDEC_BE_52, JEDEC_BE_D8, JEDEC_CE_C7). You made it better by checking for POSSIBLE_OPCODES.
Can we mark this thread as resolved?
The only question that I have left, maybe you have a chance to test at the end of the chain? Thank you!
https://review.coreboot.org/c/flashrom/+/84253/comment/7c42712f_f29733d0?usp... : PS1, Line 2078: reg
However, is it okay to just use spi_master_ich9 here? (maybe after renaming it to "spi_master_ich79" […]
Thanks for fixing! in CB:84593