Attention is currently required from: Bill XIE, Nikolai Artemiev, Peter Marheine.
Patch set 5:Code-Review +2
3 comments:
File ichspi.c:
Patch Set #1, Line 664: int oppos = 2; // use original JEDEC_BE_D8 offset
I made a separate patch CB:84567 in case it end up being useful. […]
Okay I am closing this thread
static bool ich_spi_probe_opcode(const struct flashctx *flash, uint8_t opcode)
{
return find_opcode(curopcodes, opcode) >= 0;
Please show me your elegant solution to program other erasing opcodes on the fly, but not before CB:84567 and CB:84593. ;-)
You win, you are more elegant :) I had in my mind checking inside `ich_spi_probe_opcode` for all erase opcodes, but I was thinking about hardcoded list of (JEDEC_SE, JEDEC_BE_52, JEDEC_BE_D8, JEDEC_CE_C7). You made it better by checking for POSSIBLE_OPCODES.
Can we mark this thread as resolved?
The only question that I have left, maybe you have a chance to test at the end of the chain? Thank you!
However, is it okay to just use spi_master_ich9 here? (maybe after renaming it to "spi_master_ich79" […]
Thanks for fixing! in CB:84593
To view, visit change 84253. To unsubscribe, or for help writing mail filters, visit settings.