Attention is currently required from: Simon Buhrow, Thomas Heijligen, Aarya.
Hello build bot (Jenkins), Simon Buhrow, Nico Huber, Thomas Heijligen,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/67354
to look at the new patch set (#6).
Change subject: spi.c: Add erasefn and opcodes for AT45 and S25F to lookup list
......................................................................
spi.c: Add erasefn and opcodes for AT45 and S25F to lookup list
Add opcode and erasefn for AT45 and S25F to the
spi_get_[opcode/erasefn]_from[erasefn/opcode] lookup list. Also
AT45CS1282 uses multiple opcodes in it's erasefn so modifying
aforementioned functions and the lookup list to use a list of opcodes
rather than a single opcode.
The lookup list and the passed lookup list must have opcodes in sorted
order and must be 0x00 terminated. Also the macro MAX_OPCODE must have
be one more than the maximum opcodes used by any erasefn.
Change-Id: Ief25932120f940dea0ffe161a79219deecb2e8ab
Signed-off-by: Aarya Chaumal <aarya.chaumal(a)gmail.com>
---
M flashrom.c
M include/chipdrivers.h
M sfdp.c
M spi.c
4 files changed, 80 insertions(+), 32 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/54/67354/6
--
To view, visit https://review.coreboot.org/c/flashrom/+/67354
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ief25932120f940dea0ffe161a79219deecb2e8ab
Gerrit-Change-Number: 67354
Gerrit-PatchSet: 6
Gerrit-Owner: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Simon Buhrow
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Simon Buhrow
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Evan Benn.
Peter Marheine has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67472 )
Change subject: flashrom_tester: Fix cargo check and clippy warnings
......................................................................
Patch Set 2:
(3 comments)
File util/flashrom_tester/flashrom/src/cmd.rs:
https://review.coreboot.org/c/flashrom/+/67472/comment/6e57f1bd_b1b1b2b9
PS2, Line 89: return
This can be converted to drop the `return` too?
File util/flashrom_tester/src/tests.rs:
https://review.coreboot.org/c/flashrom/+/67472/comment/b80266a5_997f1eb0
PS2, Line 135: let mut filter_names: Option<HashSet<String>> = if let Some(names) = test_names {
I think this version is easier to understand, but if you prefer the newer version then go ahead.
https://review.coreboot.org/c/flashrom/+/67472/comment/a8a498f3_b1d0e300
PS2, Line 142: .unwrap_or_else(|_| "<Unknown chip>".into());
I don't like this clippy lint; we really don't care about the cost of this allocation, and this is harder to read.
--
To view, visit https://review.coreboot.org/c/flashrom/+/67472
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I50c5af61e06df1bb6956f347cb6806a7eca6ce0e
Gerrit-Change-Number: 67472
Gerrit-PatchSet: 2
Gerrit-Owner: Evan Benn <evanbenn(a)google.com>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Evan Benn <evanbenn(a)google.com>
Gerrit-Comment-Date: Fri, 09 Sep 2022 06:21:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Evan Benn has uploaded a new patch set (#2). ( https://review.coreboot.org/c/flashrom/+/67472 )
Change subject: flashrom_tester: Fix cargo check and clippy warnings
......................................................................
flashrom_tester: Fix cargo check and clippy warnings
Change-Id: I50c5af61e06df1bb6956f347cb6806a7eca6ce0e
Signed-off-by: Evan Benn <evanbenn(a)chromium.org>
---
M util/flashrom_tester/flashrom/src/cmd.rs
M util/flashrom_tester/flashrom/src/lib.rs
M util/flashrom_tester/src/cros_sysinfo.rs
M util/flashrom_tester/src/logger.rs
M util/flashrom_tester/src/rand_util.rs
M util/flashrom_tester/src/tester.rs
M util/flashrom_tester/src/tests.rs
M util/flashrom_tester/src/utils.rs
8 files changed, 45 insertions(+), 47 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/72/67472/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/67472
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I50c5af61e06df1bb6956f347cb6806a7eca6ce0e
Gerrit-Change-Number: 67472
Gerrit-PatchSet: 2
Gerrit-Owner: Evan Benn <evanbenn(a)google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Felix Singer, Thomas Heijligen, Edward O'Callaghan, Angel Pons.
Aarya has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67093 )
Change subject: flashrom.c: Plumb 'all_skipped' global state into func param
......................................................................
Patch Set 5:
(1 comment)
File flashrom.c:
https://review.coreboot.org/c/flashrom/+/67093/comment/a853e23c_80e02ce2
PS5, Line 1053: walk_eraseblocks
> I created a new branch and cherry picked the patch on it, made changes committed them. […]
I have uploaded the patch here https://review.coreboot.org/c/flashrom/+/67470
--
To view, visit https://review.coreboot.org/c/flashrom/+/67093
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I2346c869c47b48604360b0facf9313aae086c8dd
Gerrit-Change-Number: 67093
Gerrit-PatchSet: 5
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Fri, 09 Sep 2022 05:41:24 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Singer <felixsinger(a)posteo.net>
Comment-In-Reply-To: Edward O'Callaghan <quasisec(a)chromium.org>
Comment-In-Reply-To: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Thomas Heijligen, Anastasia Klimchuk.
Edward O'Callaghan has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/66684 )
Change subject: flashrom.c: create is_internal_programmer() helper
......................................................................
Patch Set 6:
(1 comment)
Patchset:
PS6:
> I am wondering about testing. […]
It is a good question although this change in of itself does nothing more than put all the preprocessor under the one symbol.
Regarding where to from here, my advice would be to make `emergency_help_message(void)` static internal to `flashrom.c` then follow up with changing both the signature's of the printer functions to `emergency_help_message(bool) && nonfatal_help_message(bool)` so they are simple printer functions then call them as follows `xxx_help_message(is_internal_programmer());`
Past that requires more substantive changes where possibly `is_internal_programmer()` is done inside `programmer_init()` and the resulting state is stored for later use in the flashctx or force_boardmismatch becomes part of programmer_entry. All this is a little unclear at the minute without some unrelated changes to surface the underlying hidden structures that best encode what we want.
Lastly, emulating 'broken hardware' is actually relatively easy. A EM100 could emulate a bad write op for a programmer which would exercise branches such as these. As discussed in the leadership meeting we would like to see a future where the CI bot runs precisely this kind of E2E test.
--
To view, visit https://review.coreboot.org/c/flashrom/+/66684
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I43243b990192077583a9a3a95d35844923d9c158
Gerrit-Change-Number: 66684
Gerrit-PatchSet: 6
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Fri, 09 Sep 2022 02:50:52 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Kevin Yu has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/66635 )
Change subject: ichspi: Add Intel Idaville HCC support
......................................................................
Patch Set 3:
(1 comment)
Patchset:
PS3:
I check the Merge Conflict, there are many updates to the codebase, so I have resubmitted a code commit, for this one:https://review.coreboot.org/c/flashrom/+/67438
--
To view, visit https://review.coreboot.org/c/flashrom/+/66635
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I36fe5d296ed65547fbd5130abe1a0c8dd291e920
Gerrit-Change-Number: 66635
Gerrit-PatchSet: 3
Gerrit-Owner: Kevin Yu <ykevin(a)celestica.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Fri, 09 Sep 2022 01:21:45 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment