Attention is currently required from: Edward O'Callaghan.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/59276 )
Change subject: pcidev: Move pci_get_dev() logic into canonical place
......................................................................
Patch Set 3:
(1 comment)
File board_enable.c:
https://review.coreboot.org/c/flashrom/+/59276/comment/3a6df8e2_24247641
PS3, Line 1097: dev = pcidev_clonedev(dev);
NB. does the code here make sense to anyone? It looks like it's
cloning the `dev` just to leak the memory? Maybe this part was
written before the pci_dev_find_vendorclass() above?
Never mind, I figured it out, looking at the signature of
pci_get_dev() the last parameter is the function number. So
what happens here is that we match one device by vendor and
class, and depending on its ID maybe fetch the second function
under the same mult-function device. So basically another
device. Despite the leaking, the code seems to make sense.
Moving the `1` into a function with a generic name, not so
much :-/
--
To view, visit https://review.coreboot.org/c/flashrom/+/59276
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Id9ce055d5e5d347520ec5002b8c6548e60eaa0a7
Gerrit-Change-Number: 59276
Gerrit-PatchSet: 3
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Wed, 23 Feb 2022 22:32:11 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Edward O'Callaghan, Angel Pons.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/61582 )
Change subject: cli_classic: Use flashrom_init() from API
......................................................................
Patch Set 4: Code-Review+1
(1 comment)
File cli_classic.c:
https://review.coreboot.org/c/flashrom/+/61582/comment/e039f296_6c1fcac8
PS4, Line 353: /* FIXME: Delay calibration should happen in programmer code. */
Would be much less confusing if moved into flashrom_init(). But I'm
also not sure if it still applies.
--
To view, visit https://review.coreboot.org/c/flashrom/+/61582
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I07faeed876f678c35355621a080c7852eed16824
Gerrit-Change-Number: 61582
Gerrit-PatchSet: 4
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 23 Feb 2022 22:15:31 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Angel Pons, powpowd(a)gmail.com.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62061 )
Change subject: meson.build: Don't depend on getrevision.sh
......................................................................
Patch Set 3: Code-Review+2
(2 comments)
Commit Message:
https://review.coreboot.org/c/flashrom/+/62061/comment/0efb5ffe_433f0aad
PS3, Line 9: (including
: GitHub's auto-generated tarballs and ZIPs)
> (Excuse the delay; I wrote these comments immediately, but apparently they were only posted under a […]
Yep, this is a general problem, thanks for fixing it.
We don't officially support Meson for release builds, though (and won't until
somebody makes it output the same program as the Makefile). Somebody added
it with the best intentions but it's not well maintained.
File meson.build:
https://review.coreboot.org/c/flashrom/+/62061/comment/c3b1a94e_64a4a04f
PS3, Line 2: version : run_command('util/getversion.sh', '--version').stdout().strip(),
> It's intentional, yes! It makes no functional difference, but is a bit more readable.
It's best to mention such things in the commit message. If not mentioned
and not directly related to the description, reviewers won't know if it
was only added to the commit by accident.
--
To view, visit https://review.coreboot.org/c/flashrom/+/62061
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Id8601155b35f0299200c27d0278606127410ff16
Gerrit-Change-Number: 62061
Gerrit-PatchSet: 3
Gerrit-Owner: powpowd(a)gmail.com
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: powpowd(a)gmail.com
Gerrit-Comment-Date: Wed, 23 Feb 2022 22:11:17 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: powpowd(a)gmail.com
Gerrit-MessageType: comment
Attention is currently required from: Nico Huber, Angel Pons.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/61276 )
Change subject: hwaccess_x86_io: clean header concept
......................................................................
Patch Set 15:
(1 comment)
File hwaccess_x86_io.c:
https://review.coreboot.org/c/flashrom/+/61276/comment/42875515_d762fce0
PS13, Line 67: #if defined(__linux__) && !defined(__ANDROID__)
> iopl should work with all libc's on Linux. […]
I've added GNU/kFreeBSD as own target. The #if is from Makefile.d/os_test.h
--
To view, visit https://review.coreboot.org/c/flashrom/+/61276
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3
Gerrit-Change-Number: 61276
Gerrit-PatchSet: 15
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 23 Feb 2022 18:08:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: comment
Attention is currently required from: Nico Huber, Angel Pons.
Hello build bot (Jenkins), Nico Huber, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/61276
to look at the new patch set (#15).
Change subject: hwaccess_x86_io: clean header concept
......................................................................
hwaccess_x86_io: clean header concept
Move all function implementations into the .c file
Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3
Signed-off-by: Thomas Heijligen <thomas.heijligen(a)secunet.com>
---
M Makefile
M hwaccess_x86_io.c
M hwaccess_x86_io.h
M meson.build
4 files changed, 315 insertions(+), 188 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/76/61276/15
--
To view, visit https://review.coreboot.org/c/flashrom/+/61276
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3
Gerrit-Change-Number: 61276
Gerrit-PatchSet: 15
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Nico Huber, Angel Pons.
Hello build bot (Jenkins), Nico Huber, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/61276
to look at the new patch set (#14).
Change subject: hwaccess_x86_io: clean header concept
......................................................................
hwaccess_x86_io: clean header concept
Move all function implementations into the .c file
Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3
Signed-off-by: Thomas Heijligen <thomas.heijligen(a)secunet.com>
---
M Makefile
M hwaccess_x86_io.c
M hwaccess_x86_io.h
M meson.build
4 files changed, 305 insertions(+), 188 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/76/61276/14
--
To view, visit https://review.coreboot.org/c/flashrom/+/61276
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I1400704e9ac5fed00c096796536108d5bfb875e3
Gerrit-Change-Number: 61276
Gerrit-PatchSet: 14
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Felix Singer, Angel Pons.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/62197 )
Change subject: Makefile: use the HAS_ USE_ scheme for linux i2c dependent programmer
......................................................................
Patch Set 4:
(1 comment)
Commit Message:
https://review.coreboot.org/c/flashrom/+/62197/comment/b4310857_0422a7a0
PS3, Line 7: dependend
> dependen*t*
Done
--
To view, visit https://review.coreboot.org/c/flashrom/+/62197
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I47acdf89a369441b9fc664352c27c43b461545b1
Gerrit-Change-Number: 62197
Gerrit-PatchSet: 4
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 23 Feb 2022 17:35:56 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Thomas Heijligen.
Hello Felix Singer, build bot (Jenkins), Nico Huber, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/62198
to look at the new patch set (#4).
Change subject: Makefile: use libflashrom.a as input to build the flashrom executable
......................................................................
Makefile: use libflashrom.a as input to build the flashrom executable
Change-Id: Ib0091a23611cd5a1d915e56c6d0f061d74198e88
Signed-off-by: Thomas Heijligen <thomas.heijligen(a)secunet.com>
---
M Makefile
1 file changed, 5 insertions(+), 5 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/98/62198/4
--
To view, visit https://review.coreboot.org/c/flashrom/+/62198
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib0091a23611cd5a1d915e56c6d0f061d74198e88
Gerrit-Change-Number: 62198
Gerrit-PatchSet: 4
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: Felix Singer, Thomas Heijligen.
Hello Felix Singer, build bot (Jenkins), Nico Huber, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/62217
to look at the new patch set (#2).
Change subject: Makefile: add CONFIG_MEDIATEK_I2C_SPI to DEPENDS_ON_LINUX_I2C
......................................................................
Makefile: add CONFIG_MEDIATEK_I2C_SPI to DEPENDS_ON_LINUX_I2C
The Mediatek i2c spi driver requires the linux i2c stack.
Change-Id: Ic90048c549fecb8c051750a92c5b35403f07fbf4
Signed-off-by: Thomas Heijligen <thomas.heijligen(a)secunet.com>
---
M Makefile
1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/17/62217/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/62217
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ic90048c549fecb8c051750a92c5b35403f07fbf4
Gerrit-Change-Number: 62217
Gerrit-PatchSet: 2
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset