Attention is currently required from: Felix Singer, Edward O'Callaghan, Angel Pons, Alexander Goncharov.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68434 )
Change subject: tree/: Replace NULL-case of programmer_delay() with internal_delay
......................................................................
Patch Set 1: Code-Review+1
(2 comments)
Patchset:
PS1:
I like this. The cherry on the top of the cake would be to rename `internal_delay` so that it won't look like a property of internal programmer. But not in this patch.
File flashrom.c:
https://review.coreboot.org/c/flashrom/+/68434/comment/55ed01fa_b743911c
PS1, Line 282: else
else branch also needs braces as per coding style (because all previous if - else if conditions are mutiline and have braces).
--
To view, visit https://review.coreboot.org/c/flashrom/+/68434
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I1da230804d5e8f47a6e281feb66f381514dc6861
Gerrit-Change-Number: 68434
Gerrit-PatchSet: 1
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Comment-Date: Sun, 23 Oct 2022 23:57:37 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Thomas Heijligen, Edward O'Callaghan.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67475 )
Change subject: flashrom.c: Confine is_internal checks under a symbol
......................................................................
Patch Set 5: Code-Review+1
(1 comment)
Commit Message:
https://review.coreboot.org/c/flashrom/+/67475/comment/2fe85fd4_4fc8679c
PS5, Line 7: Confine is_internal checks under a symbol
This is already done in some of the earlier patches, `is_internal_programmer()` already exists in flashrom.c. May I suggest a different commit message to reflect what is happening in the latest version of this patch:
flashrom.c: Pass is_internal as an argument to *_help_message functions
Providing is_internal as an argument allows *_help_message to be pure functions without side-effects, and to do one job: printing a message.
--
To view, visit https://review.coreboot.org/c/flashrom/+/67475
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I569811798bfe310c59b8b61afba359bef68969fb
Gerrit-Change-Number: 67475
Gerrit-PatchSet: 5
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Sun, 23 Oct 2022 23:40:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Edward O'Callaghan, Angel Pons.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67474 )
Change subject: flashrom.c: Drop emergency_help_message() after erasure
......................................................................
Patch Set 5:
(1 comment)
Commit Message:
https://review.coreboot.org/c/flashrom/+/67474/comment/8933a303_bb8af04a
PS2, Line 10: agnostic
> The principle idea suggested here is not at all unreasonable and had crossed my mind already however […]
It seems to me there are two questions here:
1) do we need to show emergency message when erase failed? (and the FIXME from many years ago thinks No we don't need)
2) where should help messages live, in cli_classic or in flashrom.c?
If the answer to 1) is No, then this patch can go ahead, and 2) can be discussed and decided completely independently of this patch.
If the answer to 1) is Yes then... I made an observation that `flashrom_image_write` has 3 callsites of `emergency_help_message()`. So moving the messages to cli_classic would need to take care of `flashrom_image_write`.
I would start with answering 1)
Maybe instead of emergency message we can msg_gerr with the text similar to the text of FIXME?
--
To view, visit https://review.coreboot.org/c/flashrom/+/67474
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib0d390c44e7a851e684014925a25c8b259b810cd
Gerrit-Change-Number: 67474
Gerrit-PatchSet: 5
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Sun, 23 Oct 2022 23:18:48 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Edward O'Callaghan <quasisec(a)chromium.org>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68647 )
Change subject: Makefile: Don't install git hooks automatically
......................................................................
Patch Set 4: Code-Review+1
(2 comments)
Commit Message:
https://review.coreboot.org/c/flashrom/+/68647/comment/9f77c5e2_2675f950
PS4, Line 16:
Could you please add one more line in commit message explaining how to install git hooks? I understand that's probably `make gitconfig` but let's write in down crystal clear.
Patchset:
PS4:
I agree on the condition that we update Development guidelines straight after this patch is merged. Which means... either me or Angel will need to update that.
--
To view, visit https://review.coreboot.org/c/flashrom/+/68647
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ib83568c7ff149a8ec34ad7e92720c36a89def7bd
Gerrit-Change-Number: 68647
Gerrit-PatchSet: 4
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Comment-Date: Sun, 23 Oct 2022 22:25:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68179 )
Change subject: flash.h: extend `struct tested` with .wp field
......................................................................
Patch Set 6:
(1 comment)
Patchset:
PS4:
> Rebased. […]
I left CB:68221 not submitted and moved the comment there. Let's get other people thoughts and see how it goes.
--
To view, visit https://review.coreboot.org/c/flashrom/+/68179
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I791400889159bc6f305fb05f3e2dd9a90dbe18a4
Gerrit-Change-Number: 68179
Gerrit-PatchSet: 6
Gerrit-Owner: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sun, 23 Oct 2022 22:04:07 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Comment-In-Reply-To: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-MessageType: comment
Attention is currently required from: Nico Huber, Nikolai Artemiev, Sergii Dmytruk.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68221 )
Change subject: writeprotect.c: differentiate lack of WP from lack of implementation
......................................................................
Patch Set 7: Code-Review+2
(1 comment)
Patchset:
PS7:
Moving here the comment from patch owner:
> However, CB:68221 is probably better be abandoned. Without a reliable way of chip identification (e.g., by hashing SFDP) there can be no precise diagnostics on the status of WP for a chip as one chip record can cover unknown number of chips (including those that don't yet exist).
Do we all need to have another look?
--
To view, visit https://review.coreboot.org/c/flashrom/+/68221
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I6e75b124c21ccab51a9b5e1cd344b5310d384187
Gerrit-Change-Number: 68221
Gerrit-PatchSet: 7
Gerrit-Owner: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-Attention: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-Comment-Date: Sun, 23 Oct 2022 22:02:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67269 )
Change subject: MAINTAINERS: Add Felix Singer for test_build.sh
......................................................................
Patch Set 3: Code-Review+2
(1 comment)
File MAINTAINERS:
https://review.coreboot.org/c/flashrom/+/67269/comment/97681fb3_c0aca74b
PS3, Line 145: TEST
> I would just go with the current name. It's very subjective what one can interpret in the name. […]
Alright! I decided that adding one more person into this file is way more important than continue polishing the name of the area. This area includes only one file anyway, so confusions are highly unlikely.
I wanted to note about
> most of the time no one will look into this file anyway
This file is one of the pieces of our public documentation! We don't have too much of it (public documentation). The pieces that we have, especially the ones which are maintained and up-to-date, have high value.
However, I mark this comment as resolved. Please proceed ;)
--
To view, visit https://review.coreboot.org/c/flashrom/+/67269
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I36267e6c080b14e90e820d3e26abaefe642f9c65
Gerrit-Change-Number: 67269
Gerrit-PatchSet: 3
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Comment-Date: Sun, 23 Oct 2022 21:46:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Felix Singer <felixsinger(a)posteo.net>
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-MessageType: comment
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/68678
to look at the new patch set (#4).
Change subject: flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
......................................................................
flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
The next step appears that g_max_rom_decode is a natural
fit into the internal.c driver. Apart from 'wbsio_spi.c'
not sure what to do there???
Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Signed-off-by: Edward O'Callaghan <quasisec(a)google.com>
---
M cli_classic.c
M flashrom.c
M include/programmer.h
M internal.c
M parallel.c
M wbsio_spi.c
6 files changed, 25 insertions(+), 11 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/78/68678/4
--
To view, visit https://review.coreboot.org/c/flashrom/+/68678
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Gerrit-Change-Number: 68678
Gerrit-PatchSet: 4
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset