Edward O'Callaghan has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68674 )
Change subject: board_enable.c: plumb paralle_bus_size into board_enable_flash() helper
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/flashrom/+/68674
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I180b047fc07be946cdc5ba93871f9ff4f4c67df4
Gerrit-Change-Number: 68674
Gerrit-PatchSet: 3
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sun, 23 Oct 2022 10:28:01 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/68678
to look at the new patch set (#3).
Change subject: flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
......................................................................
flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
The next step appears that g_max_rom_decode is a natural
fit into the internal.c driver. Apart from 'wbsio_spi.c'
not sure what to do there???
Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Signed-off-by: Edward O'Callaghan <quasisec(a)google.com>
---
M cli_classic.c
M flashrom.c
M include/programmer.h
M internal.c
M parallel.c
M wbsio_spi.c
6 files changed, 25 insertions(+), 11 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/78/68678/3
--
To view, visit https://review.coreboot.org/c/flashrom/+/68678
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Gerrit-Change-Number: 68678
Gerrit-PatchSet: 3
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/68678
to look at the new patch set (#2).
Change subject: flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
......................................................................
flashrom: Rename 'max_rom_decode' to 'g_max_rom_decode'
The next step appears that g_max_rom_decode is a natural
fit into the internal.c driver. Apart from 'wbsio_spi.c'
not sure what to do there???
Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Signed-off-by: Edward O'Callaghan <quasisec(a)google.com>
---
M cli_classic.c
M flashrom.c
M include/programmer.h
M internal.c
M parallel.c
M wbsio_spi.c
6 files changed, 25 insertions(+), 11 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/78/68678/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/68678
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I22785fb196c15dea0500b650bfbc4151983d9d0e
Gerrit-Change-Number: 68678
Gerrit-PatchSet: 2
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: Edward O'Callaghan.
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/68675
to look at the new patch set (#2).
Change subject: it87spi: Plumb par bus size into it8705f_write_enable() helper
......................................................................
it87spi: Plumb par bus size into it8705f_write_enable() helper
Allow caller to query the parallel bus size.
Change-Id: Iec08cb4d56a8ca62f00b0f7323b36f7d2f850e81
Signed-off-by: Edward O'Callaghan <quasisec(a)google.com>
---
M board_enable.c
M include/programmer.h
M internal.c
M it87spi.c
4 files changed, 22 insertions(+), 10 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/75/68675/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/68675
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Iec08cb4d56a8ca62f00b0f7323b36f7d2f850e81
Gerrit-Change-Number: 68675
Gerrit-PatchSet: 2
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: Simon Buhrow, Nico Huber, Thomas Heijligen.
Hello build bot (Jenkins), Simon Buhrow, Thomas Heijligen,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/66104
to look at the new patch set (#65).
Change subject: flashrom.c: Add wrapper function to use the erase algorithm
......................................................................
flashrom.c: Add wrapper function to use the erase algorithm
Add a function to call the erase algorithm.
Change-Id: I29e3f2bd796759794184b125741a5abaac6f3ce8
Signed-off-by: Aarya Chaumal <aarya.chaumal(a)gmail.com>
---
M flashrom.c
M tests/chip_wp.c
2 files changed, 144 insertions(+), 289 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/04/66104/65
--
To view, visit https://review.coreboot.org/c/flashrom/+/66104
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I29e3f2bd796759794184b125741a5abaac6f3ce8
Gerrit-Change-Number: 66104
Gerrit-PatchSet: 65
Gerrit-Owner: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-Reviewer: Simon Buhrow
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Simon Buhrow
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newpatchset