Attention is currently required from: Tim Crawford, Michał Żygowski, David Hendricks.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/55578 )
Change subject: Add Tiger Lake U Premium support
......................................................................
Patch Set 14: Code-Review+2
(1 comment)
File ich_descriptors.c:
https://review.coreboot.org/c/flashrom/+/55578/comment/fbc20a81_d2a85239
PS13, Line 1016: if (content->CSSL != 0x11)
> Okay, done.
Thanks!
--
To view, visit https://review.coreboot.org/c/flashrom/+/55578
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I28f3b6fe9f8ce9e976a6808683f46b6f4ec72bdd
Gerrit-Change-Number: 55578
Gerrit-PatchSet: 14
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Attention: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Comment-Date: Wed, 17 Nov 2021 12:06:32 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-MessageType: comment
Attention is currently required from: Tim Crawford, Nico Huber, David Hendricks.
Michał Żygowski has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/55578 )
Change subject: Add Tiger Lake U Premium support
......................................................................
Patch Set 14:
(1 comment)
File ich_descriptors.c:
https://review.coreboot.org/c/flashrom/+/55578/comment/1ed545c2_e3e9ef1e
PS13, Line 1016: if (content->CSSL != 0x11)
> AIUI, David's wants an explicit check+return for each platform. So this should become […]
Okay, done.
--
To view, visit https://review.coreboot.org/c/flashrom/+/55578
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I28f3b6fe9f8ce9e976a6808683f46b6f4ec72bdd
Gerrit-Change-Number: 55578
Gerrit-PatchSet: 14
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Comment-Date: Wed, 17 Nov 2021 11:47:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Attention is currently required from: Tim Crawford, Michał Żygowski, David Hendricks.
Hello build bot (Jenkins), Tim Crawford, Nico Huber, David Hendricks, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/55578
to look at the new patch set (#14).
Change subject: Add Tiger Lake U Premium support
......................................................................
Add Tiger Lake U Premium support
Tiger Lake has very low ICCRIBA (TGL=0x11, CNL=0x34 and CML=0x34) and
detects as unknown chipset compatible with 300 series chipset. Add a
new enum CHIPSET_500_SERIES_TIGER_POINT and treat it identically to
CHIPSET_400_SERIES_COMET_POINT. There are some exceptions though,
ICCRIBA is no longer present n descriptor content so a new union has
been defined for new fields and used in descriptor guessing.
freq_read field is not present on Tiger Lake, moreover in CannonPoint
and Comet Point this field is used as eSPI/EC frequency, so a new
function to print read frequency has ben added. Finally Tiger lake
boot straps include eSPI, so a new bus has been added for the new
straps.
TEST=Flash BIOS region on Intel i5-1135G7
Signed-off-by: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Change-Id: I28f3b6fe9f8ce9e976a6808683f46b6f4ec72bdd
---
M chipset_enable.c
M ich_descriptors.c
M ich_descriptors.h
M ichspi.c
M programmer.h
M util/ich_descriptors_tool/ich_descriptors_tool.c
6 files changed, 92 insertions(+), 8 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/78/55578/14
--
To view, visit https://review.coreboot.org/c/flashrom/+/55578
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I28f3b6fe9f8ce9e976a6808683f46b6f4ec72bdd
Gerrit-Change-Number: 55578
Gerrit-PatchSet: 14
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Attention: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Nico Huber, Edward O'Callaghan.
Peter Marheine has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/59276 )
Change subject: pcidev: Move pci_get_dev() logic into canonical place
......................................................................
Patch Set 2: Code-Review+1
--
To view, visit https://review.coreboot.org/c/flashrom/+/59276
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Id9ce055d5e5d347520ec5002b8c6548e60eaa0a7
Gerrit-Change-Number: 59276
Gerrit-PatchSet: 2
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Wed, 17 Nov 2021 03:42:04 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Edward O'Callaghan.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/59283 )
Change subject: dmi.c: Hide has_dmi_support global behind method
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://review.coreboot.org/c/flashrom/+/59283
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ibded9714998ea6f2e5d4e0512fa7c6b105f9638a
Gerrit-Change-Number: 59283
Gerrit-PatchSet: 1
Gerrit-Owner: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Wed, 17 Nov 2021 01:59:39 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Nico Huber, Angel Pons, Sergii Dmytruk.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/59075 )
Change subject: [RFC] tests: test write protection
......................................................................
Patch Set 5:
(13 comments)
Patchset:
PS5:
Thank you for working on tests!! I did more detailed code review.
I didn't look into previous patches in this chain, but tell me if I should.
File tests/meson.build:
https://review.coreboot.org/c/flashrom/+/59075/comment/1b8079ce_3cc9d432
PS5, Line 26: write_protect
I know I asked you to rename the file, but now I did more detailed review and I think the better name would be chip_wp.c, since there are similarities with existing chip.c. How bad is to rename it again? :)
And old name is still in tests.c, tests.h so you would need to go through the code once more anyway.
Thanks!!
File tests/tests.h:
https://review.coreboot.org/c/flashrom/+/59075/comment/bb96dfa6_a862f7c5
PS5, Line 67: write_protection.c
chip_wp.c
File tests/tests.c:
https://review.coreboot.org/c/flashrom/+/59075/comment/1115a91d_69922325
PS5, Line 357: write_protection
chip_wp
https://review.coreboot.org/c/flashrom/+/59075/comment/8fe473a5_2f91010c
PS5, Line 364: write_protection.c
chip_wp.c
File tests/write_protect.c:
https://review.coreboot.org/c/flashrom/+/59075/comment/3f5c0b70_e44e4e6e
PS5, Line 27: No mocking. Using WP emulation in dummy programmer.
Maybe a complete phrase is better, like "Tests in this file do not use any mocking, because using write-protect emulation in dummyflasher programmer is sufficient".
https://review.coreboot.org/c/flashrom/+/59075/comment/fb8b3054_3c2f6241
PS5, Line 101: invalid_setup
We can be more specific in test name, since it covers invalid range (not just any invalid setup). Invalid wp range, to be even more specific. So maybe
invalid_wp_range_dummyflasher_test_success
https://review.coreboot.org/c/flashrom/+/59075/comment/37d9d026_95013534
PS5, Line 117: struct flashrom_wp_chip_config cfg;
Lets move this declaration in the beginning , together with flash, layout, mock_chip.
(And the same for other test methods)
https://review.coreboot.org/c/flashrom/+/59075/comment/3afbe98d_8de24338
PS5, Line 120: /* Invalid range. */
: range.start = 0x1000;
: range.len = 0x1000;
why chip_len is initialised at creation time, but start/len initialised separately, few lines later? they are initialised from constants anyway.
https://review.coreboot.org/c/flashrom/+/59075/comment/3fddf531_213b8902
PS5, Line 143: wp=no
I haven't looked at the rest of your chain (tell me if I should), but this looks confusing: param says "wp=no", but test name is "setup_wp". So it wp enabled or disabled? what are you testing?
https://review.coreboot.org/c/flashrom/+/59075/comment/4c246984_b2c4c0e6
PS5, Line 152: /* Use first 4 KiB for a range. */
: range.len = 0x1000;
: assert_int_equal(0, flashrom_wp_set_range(&cfg, &range));
:
: /* Change range to last 4 KiB. */
: range.start = 0x00fff000;
: assert_int_equal(0, flashrom_wp_set_range(&cfg, &range));
This code looks like as if test is testing two scenarios? If there are indeed two different scenarios, you need to split into two tests. Each test would init wp_range once (and init the rest) and then run scenario.
To have multiple assertions in one test is totally fine. But this looks like: "lets setup a range, test it works... now lets setup a different range, test it works" which should be two tests.
https://review.coreboot.org/c/flashrom/+/59075/comment/0557a3de_ab8f252e
PS5, Line 164: /* Switch modes in configuration only. */
: assert_int_equal(0, flashrom_wp_set_mode(&cfg, WP_MODE_HARDWARE));
: assert_int_equal(0, flashrom_wp_set_mode(&cfg, WP_MODE_DISABLED));
: assert_int_equal(0, flashrom_wp_set_mode(&cfg, WP_MODE_POWER_CYCLE));
: assert_int_equal(0, flashrom_wp_set_mode(&cfg, WP_MODE_PERMANENT));
Do all these need flash context, chip, layout? If not, extract into separate small tests that only declare `struct flashrom_wp_chip_config cfg;` and then do *one* assertion.
Yes, you will have many small tests! This is perfect :) Small granular tests are very easy to debug, and easy to understand what's broken when they fail on someone's patch.
https://review.coreboot.org/c/flashrom/+/59075/comment/2a56f918_722059f9
PS5, Line 170: /* Switch modes in dummyflasher. */
: assert_int_equal(0, flashrom_wp_write_chip_config(&flash, &cfg));
: assert_int_equal(0, flashrom_wp_set_mode(&cfg, WP_MODE_POWER_CYCLE));
: assert_int_equal(0, flashrom_wp_write_chip_config(&flash, &cfg));
:
: /* Check final mode. */
: assert_int_equal(0, flashrom_wp_read_chip_config(&flash, &cfg));
: assert_int_equal(0, flashrom_wp_get_mode(&cfg, &mode));
: assert_int_equal(WP_MODE_PERMANENT, mode);
Which ones of these need layout, if any?
Which ones of these need dummyflasher?
Do these actions have to be performed in this sequence, or are they independent?
Independent actions need to be independent tests.
Also for setup, you don't need to invoke heavy-weight setup if it's not needed. Ideally you only setup what you need for the given test.
Same questions apply to "wp_init_from_status_dummyflasher_test_success".
--
To view, visit https://review.coreboot.org/c/flashrom/+/59075
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I49af7f6d173eb4c56c22d80b01a473b8c499c0f8
Gerrit-Change-Number: 59075
Gerrit-PatchSet: 5
Gerrit-Owner: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maciej Pijanowski <maciej.pijanowski(a)3mdeb.com>
Gerrit-CC: Nikolai Artemiev <nartemiev(a)google.com>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Sergii Dmytruk <sergii.dmytruk(a)3mdeb.com>
Gerrit-Comment-Date: Wed, 17 Nov 2021 01:32:43 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment