Attention is currently required from: Dmitry Zhadinets, Peter Marheine.
Anastasia Klimchuk has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/86875?usp=email )
Change subject: libflashrom: Update the API for Logger Callback ......................................................................
Patch Set 7:
(3 comments)
File libflashrom.c:
https://review.coreboot.org/c/flashrom/+/86875/comment/0a9ecdc3_fa74d55b?usp... : PS7, Line 11: * in one of your commits: please add yourself here too (and in the header too) :) You are doing a lot of changes to the API
https://review.coreboot.org/c/flashrom/+/86875/comment/1cfacdff_f1abd308?usp... : PS7, Line 75: (unsigned)size+1 in here, you need spaces between +, `(unsigned)size + 1`
https://review.coreboot.org/c/flashrom/+/86875/comment/60b8ec97_1d5f41b4?usp... : PS7, Line 75: if (((unsigned)size+1) > sizeof(message)) : return -ERANGE;
Anyway, you are the boss here, and I will do like it is needed
Thank you so much for writing in that much details, this is helpful! I read everything and did lots of thinking about it.
There are few items here:
1) I agree that max length of the message is for flashrom to decide. There was no max limit, but it seems like existing messages fit into 256 chars. So we can introduce the limit, document it, and that what it would be for future. For this, the remaining part to do it document it in print function, which is in `include/flash.h` currently line 734 It should clearly say that "max message length is 256, and if the message is longer than that",
2) What to do if the message is longer? I think one thing definitely _not_ to do is silently drop the message. But current code returns an error, which is already not silent. (I don't think return value of print is checked anywhere, but it's a different story - the error is returned). So this needs to be also in documentation: "if the message is longer than limit, the error code ERANGE is returned and message is not printed. For long pieces of information, print should be called multiple times."
3) flashrom_set_loglevel() is a good idea, sorry that I haven't responded yet to that on the mailing list. I will do it after this! I think it can be in a separate commit. This one is large, and code review took a while already, and it's mentally exhaustive to carry around large commit for a long time. log level seems like a separate question (adjacent to this, but still), so it can be separate commit.
4) also
we a bit stuck here
sorry! I know sometimes code review takes a while. I very much respect other people's work. We are almost there!