Attention is currently required from: Hsuan Ting Chen, Hsuan-ting Chen, Sam McNally, Subrata Banik.
Anastasia Klimchuk has posted comments on this change by Subrata Banik. ( https://review.coreboot.org/c/flashrom/+/83144?usp=email )
Change subject: ichspi: Add support for Panther Lake ......................................................................
Patch Set 2:
(5 comments)
Patchset:
PS2: Thank you for the patch!
Commit Message:
https://review.coreboot.org/c/flashrom/+/83144/comment/4e2558fe_c9044367?usp... : PS2, Line 9: Panther Lake I am wondering, maybe there is a datasheet available? Asking for myself.
File include/programmer.h:
https://review.coreboot.org/c/flashrom/+/83144/comment/b2b591c5_c4565e9b?usp... : PS1, Line 364: /* All chipsets after METEOR_LAKE should support checking BIOS_BM to get read/write access to of FREG0~15 */
We attempted to move METEOR_LAKE to the bottom of the ich_chipset enum, but this patch reveals t […]
I think what Hsuan-ting meant to say (but correct me if I am wrong), is that we have 100 places in all ich* code that switch through the cases of ich_chipset enum, and the order is not the same between these 100 places. For example in `programmer.h` and `ichspi.c` Meteor Lake goes after Elkhart, but in `ich_descriptors.c` Meteor is before Elkhart.
I think it would be more readable to have the same order where it's possible (it is not always be possible, like pprint_freq is different). But in a separate commit, because this one adds support for Panther Lake.
what do you think?
File util/ich_descriptors_tool/ich_descriptors_tool.c:
https://review.coreboot.org/c/flashrom/+/83144/comment/62776c40_463373d8?usp... : PS2, Line 123: the chipset series with the '-c' parameter and one of the possible arguments I think you need to add panther here too
https://review.coreboot.org/c/flashrom/+/83144/comment/51840fd7_b3299d94?usp... : PS2, Line 251: else if (strcmp(csn, "panther") == 0) : cs = CHIPSET_PANTHER_LAKE; I think the ich_descriptor_tool is run separately from flashrom. Can you run it and add as one more test scenario? (and in a commit message too) Thanks!