Thomas Heijligen has submitted this change. ( https://review.coreboot.org/c/flashrom/+/67716 )
(
7 is the latest approved patch-set. No files were changed between the latest approved patch-set and the submitted one. )Change subject: spi25.c: Rename spi_get_erasefn_from_opcode to spi25_get_erasefn_from_opcode ......................................................................
spi25.c: Rename spi_get_erasefn_from_opcode to spi25_get_erasefn_from_opcode
This function works only with spi25 chips
Change-Id: Ie054160b0fdd34bcb128285c6a047e3a3fa8be0c Signed-off-by: Thomas Heijligen thomas.heijligen@secunet.com Reviewed-on: https://review.coreboot.org/c/flashrom/+/67716 Reviewed-by: Thomas Heijligen src@posteo.de Reviewed-by: Edward O'Callaghan quasisec@chromium.org Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M include/chipdrivers.h M sfdp.c M spi25.c 3 files changed, 23 insertions(+), 7 deletions(-)
Approvals: build bot (Jenkins): Verified Thomas Heijligen: Looks good to me, approved Edward O'Callaghan: Looks good to me, approved
diff --git a/include/chipdrivers.h b/include/chipdrivers.h index 34e3af8..d2e13b4 100644 --- a/include/chipdrivers.h +++ b/include/chipdrivers.h @@ -52,7 +52,7 @@ int spi_block_erase_d8(struct flashctx *flash, unsigned int addr, unsigned int blocklen); int spi_block_erase_db(struct flashctx *flash, unsigned int addr, unsigned int blocklen); int spi_block_erase_dc(struct flashctx *flash, unsigned int addr, unsigned int blocklen); -enum block_erase_func spi_get_erasefn_from_opcode(uint8_t opcode); +enum block_erase_func spi25_get_erasefn_from_opcode(uint8_t opcode); uint8_t spi_get_opcode_from_erasefn(enum block_erase_func func); int spi_chip_write_1(struct flashctx *flash, const uint8_t *buf, unsigned int start, unsigned int len); int spi_nbyte_read(struct flashctx *flash, unsigned int addr, uint8_t *bytes, unsigned int len); diff --git a/sfdp.c b/sfdp.c index ccf840f..5eddb21 100644 --- a/sfdp.c +++ b/sfdp.c @@ -81,7 +81,7 @@ { int i; uint32_t total_size = chip->total_size * 1024; - enum block_erase_func erasefn = spi_get_erasefn_from_opcode(opcode); + enum block_erase_func erasefn = spi25_get_erasefn_from_opcode(opcode);
if (erasefn == NO_BLOCK_ERASE_FUNC || total_size == 0 || block_size == 0 || total_size % block_size != 0) { diff --git a/spi25.c b/spi25.c index cae6200..f54e4c8 100644 --- a/spi25.c +++ b/spi25.c @@ -621,7 +621,7 @@ static const struct { enum block_erase_func func; uint8_t opcode; -} function_opcode_list[] = { +} spi25_function_opcode_list[] = { {SPI_BLOCK_ERASE_20, 0x20}, {SPI_BLOCK_ERASE_21, 0x21}, {SPI_BLOCK_ERASE_50, 0x50}, @@ -639,12 +639,12 @@ {SPI_BLOCK_ERASE_DC, 0xdc}, };
-enum block_erase_func spi_get_erasefn_from_opcode(uint8_t opcode) +enum block_erase_func spi25_get_erasefn_from_opcode(uint8_t opcode) { size_t i; - for (i = 0; i < ARRAY_SIZE(function_opcode_list); i++) { - if (function_opcode_list[i].opcode == opcode) - return function_opcode_list[i].func; + for (i = 0; i < ARRAY_SIZE(spi25_function_opcode_list); i++) { + if (spi25_function_opcode_list[i].opcode == opcode) + return spi25_function_opcode_list[i].func; } msg_cinfo("%s: unknown erase opcode (0x%02x). Please report " "this at flashrom@flashrom.org\n", __func__, opcode);