Edward O'Callaghan has submitted this change. ( https://review.coreboot.org/c/flashrom/+/68232 )
Change subject: rayer_spi.c: Drop lpt_outbyte intermediate var ......................................................................
rayer_spi.c: Drop lpt_outbyte intermediate var
The intermediate variable in this case serves no extra assistance in readability or additional control flow branching. Just assign the result directly into the driver state tracker.
Change-Id: Idedabb7b1c401d666b3b7e621e75704c7e765fd1 Signed-off-by: Edward O'Callaghan quasisec@google.com Reviewed-on: https://review.coreboot.org/c/flashrom/+/68232 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Angel Pons th3fanbus@gmail.com --- M rayer_spi.c 1 file changed, 20 insertions(+), 5 deletions(-)
Approvals: build bot (Jenkins): Verified Angel Pons: Looks good to me, approved
diff --git a/rayer_spi.c b/rayer_spi.c index 8eee7ab..41c5364 100644 --- a/rayer_spi.c +++ b/rayer_spi.c @@ -283,7 +283,6 @@ const struct rayer_programmer *prog = rayer_spi_types; struct rayer_pinout *pinout = NULL; uint16_t lpt_iobase; - uint8_t lpt_outbyte; char *prog_type;
if (get_params(cfg, &lpt_iobase, &prog_type) < 0) @@ -312,9 +311,6 @@ if (rget_io_perms()) return 1;
- /* Get the initial value before writing to any line. */ - lpt_outbyte = INB(lpt_iobase); - struct rayer_spi_data *data = calloc(1, sizeof(*data)); if (!data) { msg_perr("Unable to allocate space for SPI master data\n"); @@ -322,7 +318,8 @@ } data->pinout = pinout; data->lpt_iobase = lpt_iobase; - data->lpt_outbyte = lpt_outbyte; + /* Get the initial value before writing to any line. */ + data->lpt_outbyte = INB(lpt_iobase);
if (pinout->shutdown) register_shutdown(pinout->shutdown, data);