Attention is currently required from: Simon Buhrow, Edward O'Callaghan, Aarya.
Anastasia Klimchuk has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/65844 )
Change subject: flashrom.c:Add helper functions needed for new erase selction algorithm ......................................................................
Patch Set 80: Code-Review+1
(8 comments)
Commit Message:
https://review.coreboot.org/c/flashrom/+/65844/comment/8bf9aead_02a5757b PS80, Line 7: flashrom.c:Add helper functions needed for new erase selction algorithm There are few small things (missing space and one typo), having in mind 72 char limit I suggest to rephrase:
flashrom.c: Add helper functions for new erase selection algorithm
https://review.coreboot.org/c/flashrom/+/65844/comment/37bc6124_a6f9fbc2 PS80, Line 9: 1)Add a function Add space between number and text (and same for below).
Patchset:
PS78:
This patch already contains the code from CB:65879. […]
Looks like this comment resolved? Edward what do you think? I see this patch is end result of squashing 3 earlier patches.
Patchset:
PS80: I have few minor style things. Aarya, thank you so much for your work! We are almost there! :)
File erasure_layout.c:
https://review.coreboot.org/c/flashrom/+/65844/comment/c7413505_238178b1 PS80, Line 115: Remove one empty line (there are two empty lines in a row)
https://review.coreboot.org/c/flashrom/+/65844/comment/1d93b7b1_ea77511a PS80, Line 173: !! I think one exclamation mark is enough :) (and same below)
https://review.coreboot.org/c/flashrom/+/65844/comment/f09ac04e_f2917350 PS80, Line 198: if (ll->start_addr >= rstart && : ll->end_addr <= rend) { This can be one line (will be more readable)
https://review.coreboot.org/c/flashrom/+/65844/comment/81d95fe9_9f3b5592 PS80, Line 219: if (ll->start_addr >= rstart && : ll->end_addr <= rend) { Here too: make this one line, for better readability