Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Angel Pons, Alexander Goncharov.
Jean THOMAS has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67878 )
Change subject: dirtyjtag: Add DirtyJTAG programmer ......................................................................
Patch Set 11:
(6 comments)
Patchset:
PS11: Hi Angel, thanks for your feedback. I both addressed your remarks and also fixed the regression with the `programmer_entry` struct.
File dirtyjtag_spi.c:
https://review.coreboot.org/c/flashrom/+/67878/comment/fec4fd06_bdc40326 PS10, Line 79: unsigned char *
Doesn't this drop the `const` property of the data pointed by the pointer? Shouldn't it be `const un […]
`libusb_bulk_transfer`'s data parameter takes a non-const pointer (because this function can be both used for read & write transactions) hence the explicit cast.
https://review.coreboot.org/c/flashrom/+/67878/comment/8e23c51e_42e2a2b5 PS10, Line 152: 30 * i
This is because each transfer is 30 bytes, right? How about addding a constant inside the loop: […]
Each transfer is not exactly 30 bytes, they can have at most 30 bytes of payload. I'll use the constant though, it can make the code easier to read.
https://review.coreboot.org/c/flashrom/+/67878/comment/9889edf3_1a138ed4 PS10, Line 154: (const char *)transfer_buffer
Why are there casts here and inside the functions themselves? As these functions' signatures do not […]
Fixed dirtyjtag_send/_received function parameter types
https://review.coreboot.org/c/flashrom/+/67878/comment/e8a08865_b88ae7d1 PS10, Line 160: i * 30
ditto
Done
https://review.coreboot.org/c/flashrom/+/67878/comment/811a16eb_88ce058b PS10, Line 319: .map_flash_region = fallback_map, : .unmap_flash_region = fallback_unmap, : .delay = internal_delay,
Please remove
Done