Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/34661 )
Change subject: Add support for STLINK V3 debugger/programmer via it's SPI bridge ......................................................................
Patch Set 2:
(4 comments)
Looks good overall, but I'd want to have a closer look after the style issues are fixed (tabs should be 8 characters in width).
https://review.coreboot.org/c/flashrom/+/34661/2/programmer.h File programmer.h:
https://review.coreboot.org/c/flashrom/+/34661/2/programmer.h@125 PS2, Line 125: Use tab for indent, please.
https://review.coreboot.org/c/flashrom/+/34661/2/stlinkv3_spi.c File stlinkv3_spi.c:
https://review.coreboot.org/c/flashrom/+/34661/2/stlinkv3_spi.c@39 PS2, Line 39: } fw_version_check_result_t; No typedefs, please. It would hide the fact that this is an `enum` all over the code.
(And someone once told me that `_t` is reserved for standard C types.
https://review.coreboot.org/c/flashrom/+/34661/2/stlinkv3_spi.c@50 PS2, Line 50: SPI Just personal taste: I understand that SPI is an acronym and hence the urge to write it in all caps, but it doesn't seem to make it easier to read (nor to type).
https://review.coreboot.org/c/flashrom/+/34661/2/stlinkv3_spi.c@131 PS2, Line 131: actualLength `actual_length` (no CammelCase, please)