Attention is currently required from: Anton Samsonov.
Hello Anton Samsonov,
I'd like you to do a code review.
Please visit
https://review.coreboot.org/c/flashrom/+/85004?usp=email
to review the following change.
Change subject: flashchips: Update test status for Spansion S25FL256L
......................................................................
flashchips: Update test status for Spansion S25FL256L
Tested probe, read, erase, write on S25FL256LAMF01 chip
using linux_spi and dediprog (SF100) programmers.
Change-Id: I9e934791cd8d96c2cb926fd310ec48ec2ab2d1e3
Signed-off-by: Anton Samsonov <devel(a)zxlab.ru>
---
M flashchips.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/04/85004/1
diff --git a/flashchips.c b/flashchips.c
index c32159d..5ddf0b4 100644
--- a/flashchips.c
+++ b/flashchips.c
@@ -19165,7 +19165,7 @@
/* 4 x 256B Security Region (OTP) */
.feature_bits = FEATURE_WRSR_WREN | FEATURE_WRSR_EXT3 | FEATURE_OTP |
FEATURE_4BA_ENTER | FEATURE_4BA_NATIVE,
- .tested = TEST_UNTESTED,
+ .tested = TEST_OK_PREW,
.probe = PROBE_SPI_RDID,
.probe_timing = TIMING_ZERO,
.block_erasers =
--
To view, visit https://review.coreboot.org/c/flashrom/+/85004?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newchange
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9e934791cd8d96c2cb926fd310ec48ec2ab2d1e3
Gerrit-Change-Number: 85004
Gerrit-PatchSet: 1
Gerrit-Owner: Anton Samsonov <avscomputing(a)gmail.com>
Gerrit-Reviewer: Anton Samsonov <devel(a)zxlab.ru>
Gerrit-Attention: Anton Samsonov <devel(a)zxlab.ru>
Attention is currently required from: Anastasia Klimchuk, Matti Finder.
Hello Anastasia Klimchuk, Peter Marheine, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/84934?usp=email
to look at the new patch set (#6).
The following approvals got outdated and were removed:
Verified+1 by build bot (Jenkins)
Change subject: rpmc: add rpmc commands feature
......................................................................
rpmc: add rpmc commands feature
Added optional support for all the commands specified in JESD260.
Added a new optional dependency to openssls libcrypto.
Added parsing for the rpmc parameter sfdp table.
Added necessary rpmc parameter information to flashchips struct and the
flash hardening feature to enable rpmc commands.
Enables future use of these commands in the cli_client and also
libflashrom.
Change-Id: I6ab3d0446e9fd674b20550fdbfaf499b8d4a9b38
Signed-off-by: Matti Finder <matti.finder(a)gmail.com>
---
M MAINTAINERS
M include/flash.h
A include/rpmc.h
M meson.build
M meson_options.txt
A rpmc.c
M sfdp.c
7 files changed, 820 insertions(+), 17 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/34/84934/6
--
To view, visit https://review.coreboot.org/c/flashrom/+/84934?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I6ab3d0446e9fd674b20550fdbfaf499b8d4a9b38
Gerrit-Change-Number: 84934
Gerrit-PatchSet: 6
Gerrit-Owner: Matti Finder <matti.finder(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Matti Finder <matti.finder(a)gmail.com>
Attention is currently required from: Antonio Vázquez Blanco.
Anastasia Klimchuk has posted comments on this change by Antonio Vázquez Blanco. ( https://review.coreboot.org/c/flashrom/+/84982?usp=email )
Change subject: Extract usbdev declarations to a separate header.
......................................................................
Patch Set 4: Code-Review+2
--
To view, visit https://review.coreboot.org/c/flashrom/+/84982?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Gerrit-Change-Number: 84982
Gerrit-PatchSet: 4
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Miklós Márton <martonmiklosqdev(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Comment-Date: Tue, 05 Nov 2024 11:37:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/84985?usp=email
to look at the new patch set (#2).
Change subject: Extract cli_output declarations to a separate header.
......................................................................
Extract cli_output declarations to a separate header.
This is a simple refactor that aims to simplify maintenance and to
clarify file dependency inside the project.
Currently, many declarations reside in flash.h making it difficult to
really understand file dependency.
Change-Id: I45d62bd219bdbed919788ae17a64aeb119a8aac4
Signed-off-by: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
---
M cli_classic.c
M cli_output.c
A include/cli_output.h
M include/flash.h
4 files changed, 25 insertions(+), 9 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/85/84985/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/84985?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I45d62bd219bdbed919788ae17a64aeb119a8aac4
Gerrit-Change-Number: 84985
Gerrit-PatchSet: 2
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/84983?usp=email
to look at the new patch set (#2).
Change subject: Rename cli_classic.h to a more adequate cli_getop.h
......................................................................
Rename cli_classic.h to a more adequate cli_getop.h
The header only defines getop related stuff so it seems more intuitive
this way.
Also, use SPDX to reduce header comment sizes.
Change-Id: I5986828f3bdec583af6f7b02cbe1a9c45ed2000f
Signed-off-by: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
---
M cli_classic.c
M cli_getopt.c
D include/cli_classic.h
A include/cli_getopt.h
4 files changed, 50 insertions(+), 68 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/83/84983/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/84983?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I5986828f3bdec583af6f7b02cbe1a9c45ed2000f
Gerrit-Change-Number: 84983
Gerrit-PatchSet: 2
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Attention is currently required from: Anastasia Klimchuk.
Antonio Vázquez Blanco has posted comments on this change by Antonio Vázquez Blanco. ( https://review.coreboot.org/c/flashrom/+/84982?usp=email )
Change subject: Extract usbdev declarations to a separate header.
......................................................................
Patch Set 4:
(3 comments)
Patchset:
PS2:
> Antonio, thank you for your contributions! I only have comments about commit message. […]
Done! Thank you very much!
Commit Message:
https://review.coreboot.org/c/flashrom/+/84982/comment/e90abbab_b27482d4?us… :
PS2, Line 7: Split
> I would say "Extract" instead of Split.
Done
https://review.coreboot.org/c/flashrom/+/84982/comment/fddaaab9_03e0e4d9?us… :
PS2, Line 9: This is a simple refactor that aims to simplify maintenance and to clarify file dependency inside the project.
: Currently, most of the declarations reside in programmer.h making it difficult to really understand file dependency.
> We have a max width for commit message text 72 chars https://flashrom. […]
Done
--
To view, visit https://review.coreboot.org/c/flashrom/+/84982?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Gerrit-Change-Number: 84982
Gerrit-PatchSet: 4
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Miklós Márton <martonmiklosqdev(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Tue, 05 Nov 2024 09:07:04 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>
Attention is currently required from: Antonio Vázquez Blanco.
Hello Anastasia Klimchuk, Miklós Márton, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/84982?usp=email
to look at the new patch set (#4).
Change subject: Extract usbdev declarations to a separate header.
......................................................................
Extract usbdev declarations to a separate header.
This is a simple refactor that aims to simplify maintenance and to
clarify file dependency inside the project.
Currently, most of the declarations reside in programmer.h making it
difficult to really understand file dependency.
Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Signed-off-by: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
---
M dediprog.c
M developerbox_spi.c
M include/programmer.h
A include/usbdev.h
M stlinkv3_spi.c
M usbdev.c
6 files changed, 34 insertions(+), 11 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/82/84982/4
--
To view, visit https://review.coreboot.org/c/flashrom/+/84982?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Gerrit-Change-Number: 84982
Gerrit-PatchSet: 4
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Miklós Márton <martonmiklosqdev(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Attention is currently required from: Antonio Vázquez Blanco.
Hello Anastasia Klimchuk, Miklós Márton, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/84982?usp=email
to look at the new patch set (#3).
Change subject: Extract usbdev declarations to a separate header.
......................................................................
Extract usbdev declarations to a separate header.
This is a simple refactor that aims to simplify maintenance and to clarify file dependency inside the project.
Currently, most of the declarations reside in programmer.h making it difficult to really understand file dependency.
Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Signed-off-by: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
---
M dediprog.c
M developerbox_spi.c
M include/programmer.h
A include/usbdev.h
M stlinkv3_spi.c
M usbdev.c
6 files changed, 34 insertions(+), 11 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/82/84982/3
--
To view, visit https://review.coreboot.org/c/flashrom/+/84982?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Gerrit-Change-Number: 84982
Gerrit-PatchSet: 3
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Miklós Márton <martonmiklosqdev(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Attention is currently required from: Antonio Vázquez Blanco.
Anastasia Klimchuk has posted comments on this change by Antonio Vázquez Blanco. ( https://review.coreboot.org/c/flashrom/+/84982?usp=email )
The change is no longer submittable: All-Comments-Resolved is unsatisfied now.
Change subject: Split usbdev declarations to a separate header.
......................................................................
Patch Set 2:
(3 comments)
Patchset:
PS2:
Antonio, thank you for your contributions! I only have comments about commit message.
I will also review other patches a bit later. Appreciate your improvements!
Commit Message:
https://review.coreboot.org/c/flashrom/+/84982/comment/0ded5873_e31888a8?us… :
PS2, Line 7: Split
I would say "Extract" instead of Split.
https://review.coreboot.org/c/flashrom/+/84982/comment/136f0c73_0c0b5099?us… :
PS2, Line 9: This is a simple refactor that aims to simplify maintenance and to clarify file dependency inside the project.
: Currently, most of the declarations reside in programmer.h making it difficult to really understand file dependency.
We have a max width for commit message text 72 chars https://flashrom.org/dev_guide/development_guide.html#commit-message-1
Could you please wrap the message by 72 chars?
(probably in the other patches too)
--
To view, visit https://review.coreboot.org/c/flashrom/+/84982?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I9d819ea1c5bd51289d02189c1dff367ce6d25617
Gerrit-Change-Number: 84982
Gerrit-PatchSet: 2
Gerrit-Owner: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Miklós Márton <martonmiklosqdev(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Antonio Vázquez Blanco <antoniovazquezblanco(a)gmail.com>
Gerrit-Comment-Date: Tue, 05 Nov 2024 06:05:53 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Anastasia Klimchuk, Matti Finder.
Peter Marheine has posted comments on this change by Matti Finder. ( https://review.coreboot.org/c/flashrom/+/84934?usp=email )
Change subject: rpmc: add rpmc commands feature
......................................................................
Patch Set 5:
(1 comment)
File rpmc.c:
https://review.coreboot.org/c/flashrom/+/84934/comment/67fd41d4_feda1e76?us… :
PS4, Line 117: usleep(flash->chip->rpmc_ctx.polling_long_delay_write_counter_us)
> Peter, I wanted to check, is this the right way to sleep? Are we supposed to be using `programmer_de […]
`programmer_delay` seems like the right choice here, since we have a flashctx.
--
To view, visit https://review.coreboot.org/c/flashrom/+/84934?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I6ab3d0446e9fd674b20550fdbfaf499b8d4a9b38
Gerrit-Change-Number: 84934
Gerrit-PatchSet: 5
Gerrit-Owner: Matti Finder <matti.finder(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Matti Finder <matti.finder(a)gmail.com>
Gerrit-Comment-Date: Tue, 05 Nov 2024 03:37:17 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Anastasia Klimchuk <aklm(a)chromium.org>