Attention is currently required from: Simon Buhrow, Nico Huber, Paul Menzel, Aarya.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/66104 )
Change subject: flashrom.c: Add wrapper function to use the erase algorithm
......................................................................
Patch Set 52:
(2 comments)
File flashrom.c:
https://review.coreboot.org/c/flashrom/+/66104/comment/c0992810_5cd176c8
PS52, Line 1057: flashctx->chip->page_size
`flashctx->chip->gran`
However, the old code was more optimized. Maybe we can get some optimizations back.
https://review.coreboot.org/c/flashrom/+/66104/comment/509f6cbc_d9968a04
PS52, Line 1063: page_size
`gran`
--
To view, visit https://review.coreboot.org/c/flashrom/+/66104
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I29e3f2bd796759794184b125741a5abaac6f3ce8
Gerrit-Change-Number: 66104
Gerrit-PatchSet: 52
Gerrit-Owner: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-Reviewer: Simon Buhrow
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Simon Buhrow
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Aarya <aarya.chaumal(a)gmail.com>
Gerrit-Comment-Date: Mon, 12 Sep 2022 16:27:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Thomas Heijligen has submitted this change. ( https://review.coreboot.org/c/flashrom/+/67310 )
(
4 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: tests: Use MOCK_FD instead of NON_ZERO for file operations
......................................................................
tests: Use MOCK_FD instead of NON_ZERO for file operations
NON_ZERO can be a negative number, so MOCK_FD is safer option to
use as a mock file descriptor. Also it is more readable.
BUG=b:237606255
TEST=ninja test (on linux)
Change-Id: I097dd59f69c3fb532ac136796fcf5cae8839af7b
TICKET: https://ticket.coreboot.org/issues/411
Signed-off-by: Anastasia Klimchuk <aklm(a)chromium.org>
Reviewed-on: https://review.coreboot.org/c/flashrom/+/67310
Reviewed-by: Felix Singer <felixsinger(a)posteo.net>
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
Reviewed-by: Alexander Goncharov <chat(a)joursoir.net>
Reviewed-by: Thomas Heijligen <src(a)posteo.de>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M tests/tests.c
1 file changed, 25 insertions(+), 2 deletions(-)
Approvals:
build bot (Jenkins): Verified
Felix Singer: Looks good to me, approved
Thomas Heijligen: Looks good to me, approved
Angel Pons: Looks good to me, approved
Alexander Goncharov: Looks good to me, but someone else must approve
diff --git a/tests/tests.c b/tests/tests.c
index 7a448d4..8e3fdde 100644
--- a/tests/tests.c
+++ b/tests/tests.c
@@ -24,7 +24,7 @@
void *not_null(void)
{
- return (void *)NON_ZERO;
+ return (void *)MOCK_FD;
}
/* Workaround for https://github.com/clibs/cmocka/issues/17 */
@@ -253,7 +253,7 @@
int __wrap_fileno(FILE *fp)
{
LOG_ME;
- return NON_ZERO;
+ return MOCK_FD;
}
int __wrap_fsync(int fd)
--
To view, visit https://review.coreboot.org/c/flashrom/+/67310
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I097dd59f69c3fb532ac136796fcf5cae8839af7b
Gerrit-Change-Number: 67310
Gerrit-PatchSet: 6
Gerrit-Owner: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Idwer Vollering <vidwer(a)gmail.com>
Gerrit-MessageType: merged
Attention is currently required from: Felix Singer, Nico Huber, Angel Pons, Anastasia Klimchuk.
Thomas Heijligen has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/66475 )
Change subject: test_build.sh: Build all programmers individually using Meson
......................................................................
Patch Set 12: Code-Review+1
(1 comment)
File test_build.sh:
https://review.coreboot.org/c/flashrom/+/66475/comment/6c1a8130_7480618c
PS12, Line 48: local
I think we've said not to use `local` to be compatible with non bash shells
--
To view, visit https://review.coreboot.org/c/flashrom/+/66475
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I703127a2dc31d316d3d1c842b5bcb0b22c39c0d4
Gerrit-Change-Number: 66475
Gerrit-PatchSet: 12
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Mon, 12 Sep 2022 12:19:17 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/67541
to look at the new patch set (#3).
Change subject: test_build.sh: Delete old build dir when Meson is used
......................................................................
test_build.sh: Delete old build dir when Meson is used
Make sure to start from a clean environment when Meson is used. Also,
rename the variable "builddir" to "build_dir" for better readability and
to avoid typos.
Signed-off-by: Felix Singer <felixsinger(a)posteo.net>
Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
---
M test_build.sh
1 file changed, 21 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/41/67541/3
--
To view, visit https://review.coreboot.org/c/flashrom/+/67541
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
Gerrit-Change-Number: 67541
Gerrit-PatchSet: 3
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Thomas Heijligen has uploaded this change for review. ( https://review.coreboot.org/c/flashrom/+/67551 )
Change subject: test_build.sh: build all programmers with meson
......................................................................
test_build.sh: build all programmers with meson
Not all programmers are enabled by default with meson. Use
`-Dprogrammer=all` to enable them.
Change-Id: I43c7abdf07c41746f23200cae03148c152c5fd28
Signed-off-by: Thomas Heijligen <thomas.heijligen(a)secunet.com>
---
M test_build.sh
1 file changed, 14 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/51/67551/1
diff --git a/test_build.sh b/test_build.sh
index c11d982..d8e62e5 100755
--- a/test_build.sh
+++ b/test_build.sh
@@ -39,7 +39,7 @@
build_meson () {
builddir=out
rm -rf $builddir
- meson $builddir -Dtests=enabled
+ meson $builddir -Dtests=enabled -Dprogrammer=all
ninja -C $builddir
ninja -C $builddir test
}
--
To view, visit https://review.coreboot.org/c/flashrom/+/67551
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I43c7abdf07c41746f23200cae03148c152c5fd28
Gerrit-Change-Number: 67551
Gerrit-PatchSet: 1
Gerrit-Owner: Thomas Heijligen <src(a)posteo.de>
Gerrit-MessageType: newchange
Felix Singer has uploaded a new patch set (#2). ( https://review.coreboot.org/c/flashrom/+/67541 )
Change subject: test_build.sh: Delete old build dir when Meson is used
......................................................................
test_build.sh: Delete old build dir when Meson is used
Make sure to start from a clean environment when Meson is used.
Signed-off-by: Felix Singer <felixsinger(a)posteo.net>
Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
---
M test_build.sh
1 file changed, 19 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/41/67541/2
--
To view, visit https://review.coreboot.org/c/flashrom/+/67541
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
Gerrit-Change-Number: 67541
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-MessageType: newpatchset
Felix Singer has uploaded this change for review. ( https://review.coreboot.org/c/flashrom/+/67541 )
Change subject: test_build.sh: Delete old build dir when Meson is used
......................................................................
test_build.sh: Delete old build dir when Meson is used
Make sure to start from a clean environment when Meson is used.
Signed-off-by: Felix Singer <felixsinger(a)posteo.net>
Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
---
M test_build.sh
1 file changed, 15 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/41/67541/1
diff --git a/test_build.sh b/test_build.sh
index b2320b8..041a341 100755
--- a/test_build.sh
+++ b/test_build.sh
@@ -38,6 +38,9 @@
build_meson () {
builddir=out
+
+ rm -rf ${buildir}
+
meson $builddir -Dtests=enabled
ninja -C $builddir
ninja -C $builddir test
--
To view, visit https://review.coreboot.org/c/flashrom/+/67541
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I050ed916685728cbed9c10601a6bcad6d59a4eda
Gerrit-Change-Number: 67541
Gerrit-PatchSet: 1
Gerrit-Owner: Felix Singer <felixsinger(a)posteo.net>
Gerrit-MessageType: newchange