Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Jean THOMAS, Alexander Goncharov.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67878 )
Change subject: dirtyjtag: Add DirtyJTAG programmer
......................................................................
Patch Set 11: Code-Review+1
(3 comments)
File dirtyjtag_spi.c:
https://review.coreboot.org/c/flashrom/+/67878/comment/32007aec_1db098cf
PS10, Line 79: unsigned char *
> `libusb_bulk_transfer`'s data parameter takes a non-const pointer (because this function can be both […]
Ack, there's a way to avoid casting away the `const`: not using `const` to begin with. See comment on latest patchset.
File dirtyjtag_spi.c:
https://review.coreboot.org/c/flashrom/+/67878/comment/8eca82ec_5cc66017
PS11, Line 74: const
Let's drop the `const` from the parameter, so that the `const` doesn't need to be cast away.
https://review.coreboot.org/c/flashrom/+/67878/comment/6bcb33cd_a0092120
PS11, Line 167: const
This `const` would also need to be dropped.
--
To view, visit https://review.coreboot.org/c/flashrom/+/67878
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913
Gerrit-Change-Number: 67878
Gerrit-PatchSet: 11
Gerrit-Owner: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Attention: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Comment-Date: Sun, 09 Oct 2022 22:23:52 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Angel Pons, Alexander Goncharov.
Jean THOMAS has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67878 )
Change subject: dirtyjtag: Add DirtyJTAG programmer
......................................................................
Patch Set 11:
(6 comments)
Patchset:
PS11:
Hi Angel, thanks for your feedback. I both addressed your remarks and also fixed the regression with the `programmer_entry` struct.
File dirtyjtag_spi.c:
https://review.coreboot.org/c/flashrom/+/67878/comment/fec4fd06_bdc40326
PS10, Line 79: unsigned char *
> Doesn't this drop the `const` property of the data pointed by the pointer? Shouldn't it be `const un […]
`libusb_bulk_transfer`'s data parameter takes a non-const pointer (because this function can be both used for read & write transactions) hence the explicit cast.
https://review.coreboot.org/c/flashrom/+/67878/comment/8e23c51e_42e2a2b5
PS10, Line 152: 30 * i
> This is because each transfer is 30 bytes, right? How about addding a constant inside the loop: […]
Each transfer is not exactly 30 bytes, they can have at most 30 bytes of payload. I'll use the constant though, it can make the code easier to read.
https://review.coreboot.org/c/flashrom/+/67878/comment/9889edf3_1a138ed4
PS10, Line 154: (const char *)transfer_buffer
> Why are there casts here and inside the functions themselves? As these functions' signatures do not […]
Fixed dirtyjtag_send/_received function parameter types
https://review.coreboot.org/c/flashrom/+/67878/comment/e8a08865_b88ae7d1
PS10, Line 160: i * 30
> ditto
Done
https://review.coreboot.org/c/flashrom/+/67878/comment/811a16eb_88ce058b
PS10, Line 319: .map_flash_region = fallback_map,
: .unmap_flash_region = fallback_unmap,
: .delay = internal_delay,
> Please remove
Done
--
To view, visit https://review.coreboot.org/c/flashrom/+/67878
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913
Gerrit-Change-Number: 67878
Gerrit-PatchSet: 11
Gerrit-Owner: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Comment-Date: Sun, 09 Oct 2022 21:32:47 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Jean THOMAS, Alexander Goncharov.
Hello Felix Singer, build bot (Jenkins), Nico Huber, Thomas Heijligen, Angel Pons,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/67878
to look at the new patch set (#11).
Change subject: dirtyjtag: Add DirtyJTAG programmer
......................................................................
dirtyjtag: Add DirtyJTAG programmer
Add a new programmer driver for the DirtyJTAG project (a USB-JTAG
firmware for STM32 MCUs).
Successfully tested with DirtyJTAG 1.4 running on an Olimex STM32-H103
development board and a SST25VF020B SPI flash chip.
Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913
Signed-off-by: Jean THOMAS <virgule(a)jeanthomas.me>
---
M Makefile
A dirtyjtag_spi.c
M flashrom.8.tmpl
M include/programmer.h
M meson.build
M meson_options.txt
M programmer_table.c
M test_build.sh
8 files changed, 379 insertions(+), 5 deletions(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/78/67878/11
--
To view, visit https://review.coreboot.org/c/flashrom/+/67878
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913
Gerrit-Change-Number: 67878
Gerrit-PatchSet: 11
Gerrit-Owner: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Attention: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-MessageType: newpatchset
Attention is currently required from: Felix Singer, Nico Huber, Thomas Heijligen, Jean THOMAS, Alexander Goncharov.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/67878 )
Change subject: dirtyjtag: Add DirtyJTAG programmer
......................................................................
Patch Set 10:
(4 comments)
File dirtyjtag_spi.c:
https://review.coreboot.org/c/flashrom/+/67878/comment/9ae80495_5cb1f9e6
PS10, Line 79: unsigned char *
Doesn't this drop the `const` property of the data pointed by the pointer? Shouldn't it be `const unsigned char *` instead?
https://review.coreboot.org/c/flashrom/+/67878/comment/1df383af_6c9e4bd0
PS10, Line 152: 30 * i
This is because each transfer is 30 bytes, right? How about addding a constant inside the loop:
const size_t xfer_offset = 30 * i;
https://review.coreboot.org/c/flashrom/+/67878/comment/a90eb49a_9e828629
PS10, Line 154: (const char *)transfer_buffer
Why are there casts here and inside the functions themselves? As these functions' signatures do not depend on external constraints (e.g. used as value for a function pointer), we can retype the parameters to avoid the double cast.
https://review.coreboot.org/c/flashrom/+/67878/comment/5e6150bb_b3481de1
PS10, Line 160: i * 30
ditto
--
To view, visit https://review.coreboot.org/c/flashrom/+/67878
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: Ic43e9a014ed7d04e429e73b30c9dcfdde1a78913
Gerrit-Change-Number: 67878
Gerrit-PatchSet: 10
Gerrit-Owner: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Thomas Heijligen <src(a)posteo.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Thomas Heijligen <src(a)posteo.de>
Gerrit-Attention: Jean THOMAS <virgule(a)jeanthomas.me>
Gerrit-Attention: Alexander Goncharov <chat(a)joursoir.net>
Gerrit-Comment-Date: Sun, 09 Oct 2022 16:13:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Edward O'Callaghan.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/68239 )
Change subject: rayer_spi.c: Get rid of temporary `prog_type` string
......................................................................
Patch Set 3: Code-Review+2
(1 comment)
Patchset:
PS3:
+2'ing each other's work
--
To view, visit https://review.coreboot.org/c/flashrom/+/68239
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: flashrom
Gerrit-Branch: master
Gerrit-Change-Id: I83e34382ee9814f224025e21e5099fdab73cee8c
Gerrit-Change-Number: 68239
Gerrit-PatchSet: 3
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Comment-Date: Sun, 09 Oct 2022 11:23:58 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment