Attention is currently required from: Thomas Heijligen, Angel Pons. Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/58883 )
Change subject: pci.h: move include into own wrapper ......................................................................
Patch Set 1:
(1 comment)
File hwaccess.h:
https://review.coreboot.org/c/flashrom/+/58883/comment/40afbd8a_bd371407 PS1, Line 36: #define pci_mmio_writeb mmio_le_writeb : #define pci_mmio_writew mmio_le_writew : #define pci_mmio_writel mmio_le_writel : #define pci_mmio_readb mmio_le_readb : #define pci_mmio_readw mmio_le_readw : #define pci_mmio_readl mmio_le_readl
Since these are only aliases of the mmio_le/be_readX/writeX we could use the mmio_le/be_readX/writeX functions in every part of the code.
You mean replacing "calls" to pci_mmio* with the underlying function name?
Maybe syncing the name scheme with the (not yet merged) read_le8 type of functions. as read_volatile_le8
Hmm, I would prefer to keep `mmio` in the name, how about `mmio_read_le8`?