Attention is currently required from: Simon Buhrow, Edward O'Callaghan.
Aarya has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/65844 )
Change subject: flashrom.c:Add a function to get list of sectors that need erasing ......................................................................
Patch Set 56:
(5 comments)
File flashrom.c:
https://review.coreboot.org/c/flashrom/+/65844/comment/6d32e3b6_7b2805a8 PS56, Line 1203: {
`layout[function_index]. […]
That would complicate the recursion probably?
https://review.coreboot.org/c/flashrom/+/65844/comment/0d139f69_ce6d20cc PS56, Line 1204: ) : {
`) {`
Done
https://review.coreboot.org/c/flashrom/+/65844/comment/074d9e65_1ed456f9 PS56, Line 1214: } : else {
`} else {`
Done
https://review.coreboot.org/c/flashrom/+/65844/comment/47520377_e772a495 PS56, Line 1220: r(
nit: `for (`
Done
https://review.coreboot.org/c/flashrom/+/65844/comment/20861912_8360099d PS56, Line 1225: (sub_block_end - sub_block_start + 1)/2
hmm, maybe good to use a const intermediate here for clarity.
Done