Ryan O'Leary has posted comments on this change. ( https://review.coreboot.org/c/flashrom/+/34160 )
Change subject: dediprog.c: Add id parameter to dediprog programmer ......................................................................
Patch Set 3:
(4 comments)
I removed the dediprog_id_prefix function because I had a SF100 which did not follow this naming scheme.
https://review.coreboot.org/c/flashrom/+/34160/2/dediprog.c File dediprog.c:
https://review.coreboot.org/c/flashrom/+/34160/2/dediprog.c@826 PS2, Line 826: /* Read the id from the dediprog. This should return the numeric part of the
Please start comments with /* on a separate line.
Done
https://review.coreboot.org/c/flashrom/+/34160/2/dediprog.c@1089 PS2, Line 1089: strlen(prefix) != 2
This is true by definition.
Done
https://review.coreboot.org/c/flashrom/+/34160/2/dediprog.c@1094 PS2, Line 1094: dediprog_id_prefix(id)
or just `prefix`
Done
https://review.coreboot.org/c/flashrom/+/34160/2/dediprog.c@1229 PS2, Line 1229: }
One thought to make this whole looping easier to read (not 100% sure if […]
Done. Thanks!