Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/19673
to look at the new patch set (#2).
Change subject: dediprog: Add socket support for SF600
......................................................................
dediprog: Add socket support for SF600
This enables use of the socket rather than clip on SF600 programmers.
Change-Id: I5fd4133f08882d60ac596273ab8aa9dab893c9cd
Signed-off-by: David Hendricks <dhendricks(a)fb.com>
---
M dediprog.c
1 file changed, 9 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/73/19673/2
--
To view, visit https://review.coreboot.org/19673
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I5fd4133f08882d60ac596273ab8aa9dab893c9cd
Gerrit-PatchSet: 2
Gerrit-Project: flashrom
Gerrit-Branch: staging
Gerrit-Owner: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Nico Huber has posted comments on this change. ( https://review.coreboot.org/17946 )
Change subject: Add a convenient libflashrom interface
......................................................................
Patch Set 10:
(1 comment)
https://review.coreboot.org/#/c/17946/10/flash.h
File flash.h:
PS10, Line 142: /* TODO: Agree on a name and convert all occurences.
> I think the scope of this struct has grown beyond context of the flash chip
That depends on future design decisions, so I didn't want to go
through a huge renaming twice. One question is, will we have one
huge context for everything? or will we keep a per chip context
that only lives from probing on? Stefan has patches to revise the
probing btw (hadn't the time to look at them yet)...
The current libflashrom interface suggests that we have two types
of contexts `flashrom_programmer` and `flashrom_flashctx`. But we
could still use a single context in the implementation. I just
wanted to keep all options open. With that said, a next step could
be to implement `flashrom_programmer` (starting with the flags,
they really don't belong in the chip's context).
With a single huge context, OTOH, we'd have aliases in the imple-
mentation if we keep both structs in the interface (what I'd pre-
fer). Then I'd agree to `flashrom_ctx` or `flashrom_context` in
the implementation.
In either case, we might want to look for a better name for
`flashrom_flashctx` in the interface too. Maybe `flashrom_flash`
or `flashrom_flashchip`? IMO, both would be a better match for
`flashrom_programmer`.
Last but not least, I don't want to annoy Stefan any further with
unnecessary renaming atm. It would create a huge burden for anyone
rebasing more invasive patches. And I think he's right with that.
So we can discuss the names if you want, but I'd want to keep the
alias until we have more of the larger patches in.
--
To view, visit https://review.coreboot.org/17946
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I00f169990830aa17b7dfae5eb74010d40c476181
Gerrit-PatchSet: 10
Gerrit-Project: flashrom
Gerrit-Branch: staging
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
David Hendricks has posted comments on this change. ( https://review.coreboot.org/17946 )
Change subject: Add a convenient libflashrom interface
......................................................................
Patch Set 10: Code-Review-1
(1 comment)
One last thing to bikeshed, otherwise LGTM.
https://review.coreboot.org/#/c/17946/10/flash.h
File flash.h:
PS10, Line 142: /* TODO: Agree on a name and convert all occurences.
I think the scope of this struct has grown beyond context of the flash chip. How about flashrom_ctx or flashrom_context?
--
To view, visit https://review.coreboot.org/17946
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I00f169990830aa17b7dfae5eb74010d40c476181
Gerrit-PatchSet: 10
Gerrit-Project: flashrom
Gerrit-Branch: staging
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: Yes
David Hendricks has posted comments on this change. ( https://review.coreboot.org/17944 )
Change subject: Give layouts their own type
......................................................................
Patch Set 6: Code-Review+2
--
To view, visit https://review.coreboot.org/17944
To unsubscribe, visit https://review.coreboot.org/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: Icea1a58c283131cc9c5fde6f16d783538dc1a4c7
Gerrit-PatchSet: 6
Gerrit-Project: flashrom
Gerrit-Branch: staging
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-HasComments: No