Attention is currently required from: Dmitry Zhadinets.
Peter Marheine has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/87047?usp=email )
Change subject: libflashrom: Add set log level functionality
......................................................................
Patch Set 6:
(1 comment)
File libflashrom.c:
https://review.coreboot.org/c/flashrom/+/87047/comment/9ff9e5a1_eb94b135?us… :
PS6, Line 36: enum flashrom_log_level global_log_level = FLASHROM_MSG_INFO;
It doesn't look like this needs external linkage, so it should be `static`.
```suggestion
static enum flashrom_log_level global_log_level = FLASHROM_MSG_INFO;
```
--
To view, visit https://review.coreboot.org/c/flashrom/+/87047?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I095d48b8feb5fbc950a36eb17bed0d7cb8d9df64
Gerrit-Change-Number: 87047
Gerrit-PatchSet: 6
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: NyeonWoo Kim
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Comment-Date: Mon, 31 Mar 2025 22:16:12 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Anastasia Klimchuk, Dmitry Zhadinets.
Peter Marheine has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/86875?usp=email )
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
Patch Set 13: Code-Review+2
(1 comment)
File include/flash.h:
https://review.coreboot.org/c/flashrom/+/86875/comment/8fab3e7f_562f7223?us… :
PS13, Line 738: Therefore, any message exceeding 256 characters will not be printed,
It now gets truncated.
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 13
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Mon, 31 Mar 2025 22:11:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: Dmitry Zhadinets.
Anastasia Klimchuk has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/87047?usp=email )
Change subject: libflashrom: Add set log level functionality
......................................................................
Patch Set 6:
(4 comments)
Patchset:
PS6:
Thank you! you implemented a TODO which was here for so long!
File libflashrom.c:
https://review.coreboot.org/c/flashrom/+/87047/comment/2dd0092e_c0533fd0?us… :
PS6, Line 6: *
I think it's about time to add a line for yourself here, and in the header, you are doing significant changes (and there are even more changes coming next)
File tests/libflashrom.c:
https://review.coreboot.org/c/flashrom/+/87047/comment/b484f27b_6124910d?us… :
PS6, Line 66: (void)state; /* unused */
: int user_data = 100500;
: flashrom_set_log_callback_v2(test_log_callback_v2, &user_data);
: flashrom_set_log_level(FLASHROM_MSG_WARN);
For readability, could you please re-arrange lines a bit, and add few new lines:
```
(void)state; /* unused */
flashrom_set_log_level(FLASHROM_MSG_WARN);
/* v2 API check */
int user_data = 100500;
flashrom_set_log_callback_v2(test_log_callback_v2, &user_data);
....and the rest of the block as is
```
flashrom_set_log_level makes impact on all the code below, so I wanted it to be more visible
https://review.coreboot.org/c/flashrom/+/87047/comment/f5fae930_92454a7d?us… :
PS6, Line 91: /* check that callback is called after the change*/
maybe a new line between 90-91, again so that flashrom_set_log_level be easily visible
--
To view, visit https://review.coreboot.org/c/flashrom/+/87047?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: I095d48b8feb5fbc950a36eb17bed0d7cb8d9df64
Gerrit-Change-Number: 87047
Gerrit-PatchSet: 6
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: NyeonWoo Kim
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Comment-Date: Mon, 31 Mar 2025 08:45:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Anastasia Klimchuk, Peter Marheine.
Hello Anastasia Klimchuk, Peter Marheine, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/86875?usp=email
to look at the new patch set (#13).
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
libflashrom: Update the API for Logger Callback
The initial implementation does not account for user_data, requiring
the calling application to use a global scope. This may lead to issues
related to object lifecycle management and other architectural
concerns.
This patch adds user_data to the user’s log callback. Moreover, it
performs message formatting, so the application only needs to pass
the formatted string to the selected output.
The change does not break the existing logging API but extends it.
A new API version is introduced with the v2 suffix.
Testing: Both unit tests and CLI tools serve as libflashrom clients.
All unit tests run successfully.
Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Signed-off-by: Dmitry Zhadinets <dzhadinets(a)gmail.com>
---
M include/flash.h
M include/libflashrom.h
M libflashrom.c
M libflashrom.map
M meson.build
M meson_options.txt
A tests/libflashrom.c
M tests/meson.build
M tests/tests.c
M tests/tests.h
10 files changed, 153 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/75/86875/13
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 13
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Peter Marheine <pmarheine(a)chromium.org>
Attention is currently required from: Anastasia Klimchuk, Peter Marheine.
Dmitry Zhadinets has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/86875?usp=email )
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
Patch Set 11:
(2 comments)
File libflashrom.c:
https://review.coreboot.org/c/flashrom/+/86875/comment/2f13ff77_993ec893?us… :
PS11, Line 68: va_copy(args_attempt, args);
> This size is no longer useful; we can omit this first `vsprintf` completely because the buffer is no […]
Done
https://review.coreboot.org/c/flashrom/+/86875/comment/0cdc7448_b5449d91?us… :
PS11, Line 80: ld
> Use `z` since this should be `size_t` (due to `sizeof`).
Done
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 11
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Comment-Date: Mon, 31 Mar 2025 03:16:33 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Peter Marheine <pmarheine(a)chromium.org>
Attention is currently required from: Anastasia Klimchuk, Dmitry Zhadinets.
Hello Anastasia Klimchuk, Peter Marheine, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/86875?usp=email
to look at the new patch set (#12).
The following approvals got outdated and were removed:
Verified+1 by build bot (Jenkins)
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
libflashrom: Update the API for Logger Callback
The initial implementation does not account for user_data, requiring
the calling application to use a global scope. This may lead to issues
related to object lifecycle management and other architectural
concerns.
This patch adds user_data to the user’s log callback. Moreover, it
performs message formatting, so the application only needs to pass
the formatted string to the selected output.
The change does not break the existing logging API but extends it.
A new API version is introduced with the v2 suffix.
Testing: Both unit tests and CLI tools serve as libflashrom clients.
All unit tests run successfully.
Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Signed-off-by: Dmitry Zhadinets <dzhadinets(a)gmail.com>
---
M include/flash.h
M include/libflashrom.h
M libflashrom.c
M libflashrom.map
M meson.build
M meson_options.txt
A tests/libflashrom.c
M tests/meson.build
M tests/tests.c
M tests/tests.h
10 files changed, 149 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/75/86875/12
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 12
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Attention is currently required from: Anastasia Klimchuk, Dmitry Zhadinets.
Peter Marheine has posted comments on this change by Dmitry Zhadinets. ( https://review.coreboot.org/c/flashrom/+/86875?usp=email )
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
Patch Set 11:
(2 comments)
File libflashrom.c:
https://review.coreboot.org/c/flashrom/+/86875/comment/808db232_b1b0c923?us… :
PS11, Line 68: va_copy(args_attempt, args);
This size is no longer useful; we can omit this first `vsprintf` completely because the buffer is now statically allocated.
https://review.coreboot.org/c/flashrom/+/86875/comment/5c2b0609_87d01021?us… :
PS11, Line 80: ld
Use `z` since this should be `size_t` (due to `sizeof`).
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 11
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Comment-Date: Mon, 31 Mar 2025 03:01:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Michał Kopeć.
Anastasia Klimchuk has posted comments on this change by Michał Kopeć. ( https://review.coreboot.org/c/flashrom/+/87045?usp=email )
Change subject: chipset_enable.c: Mark Intel B150 and Q170 as tested
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/flashrom/+/87045?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iedf4c77e3228628ac1a8726c1a9b4fb733d63d40
Gerrit-Change-Number: 87045
Gerrit-PatchSet: 1
Gerrit-Owner: Michał Kopeć <michal.kopec(a)3mdeb.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Michał Kopeć <michal.kopec(a)3mdeb.com>
Gerrit-Comment-Date: Mon, 31 Mar 2025 02:14:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: Anastasia Klimchuk, Peter Marheine.
Hello Anastasia Klimchuk, Peter Marheine, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/flashrom/+/86875?usp=email
to look at the new patch set (#11).
Change subject: libflashrom: Update the API for Logger Callback
......................................................................
libflashrom: Update the API for Logger Callback
The initial implementation does not account for user_data, requiring
the calling application to use a global scope. This may lead to issues
related to object lifecycle management and other architectural
concerns.
This patch adds user_data to the user’s log callback. Moreover, it
performs message formatting, so the application only needs to pass
the formatted string to the selected output.
The change does not break the existing logging API but extends it.
A new API version is introduced with the v2 suffix.
Testing: Both unit tests and CLI tools serve as libflashrom clients.
All unit tests run successfully.
Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Signed-off-by: Dmitry Zhadinets <dzhadinets(a)gmail.com>
---
M include/flash.h
M include/libflashrom.h
M libflashrom.c
M libflashrom.map
M meson.build
M meson_options.txt
A tests/libflashrom.c
M tests/meson.build
M tests/tests.c
M tests/tests.h
10 files changed, 157 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/flashrom refs/changes/75/86875/11
--
To view, visit https://review.coreboot.org/c/flashrom/+/86875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: flashrom
Gerrit-Branch: main
Gerrit-Change-Id: Iea738bd371fa3d69b9cf222c89ee67490d30af39
Gerrit-Change-Number: 86875
Gerrit-PatchSet: 11
Gerrit-Owner: Dmitry Zhadinets <dzhadinets(a)gmail.com>
Gerrit-Reviewer: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Reviewer: Peter Marheine <pmarheine(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Anastasia Klimchuk <aklm(a)chromium.org>
Gerrit-Attention: Peter Marheine <pmarheine(a)chromium.org>