This patch changes the prefix of chip constant #defines in the following way:
AM_nnnnnnn -> AMD_AMnnnnnnn AT_nnnnnnn -> ATMEL_ATnnnnnnn EN_nnnnnnn -> EON_ENnnnnnnn MBMnnnnnnn -> FUJITSU_MBMnnnnnnn MX_ID -> MACRONIX_ID MX_nnnnnnn -> MACRONIX_MXnnnnnnn PMC_nnnnnnn -> PMC_PMnnnnnnn SST_nnnnnnn -> SST_SSTnnnnnnn
It leaves the Intel #defines alone because there is another pending patch for that: http://patchwork.coreboot.org/patch/1937/
Some background discussion here: http://www.flashrom.org/pipermail/flashrom/2010-July/004059.html
Signed-off-by: Mattias Mattsson vitplister@gmail.com
On 15.09.2010 04:04, Mattias Mattsson wrote:
This patch changes the prefix of chip constant #defines in the following way:
AM_nnnnnnn -> AMD_AMnnnnnnn AT_nnnnnnn -> ATMEL_ATnnnnnnn EN_nnnnnnn -> EON_ENnnnnnnn MBMnnnnnnn -> FUJITSU_MBMnnnnnnn MX_ID -> MACRONIX_ID MX_nnnnnnn -> MACRONIX_MXnnnnnnn PMC_nnnnnnn -> PMC_PMnnnnnnn SST_nnnnnnn -> SST_SSTnnnnnnn
It leaves the Intel #defines alone because there is another pending patch for that: http://patchwork.coreboot.org/patch/1937/
Some background discussion here: http://www.flashrom.org/pipermail/flashrom/2010-July/004059.html
Signed-off-by: Mattias Mattsson vitplister@gmail.com
.name = "Am29LV081B",
.model_id = AMD_AM29LV080B,
This looks odd. Chip name and model_id don't match.
EN25B*
The whole EN25B family seems to be in desperate need of FEATURE_EVIL_TWIN unless the IDs are incorrect. Admittedly your patch doesn't make it worse, but this area is in desperate need of fixing.
.name = "Pm39LV010",
.model_id = PMC_PM39F010, /* Pm39LV010 and Pm39F010 have identical IDs but different voltage */
name/model_id mismatch. Besides that, we probably want all names in .name
.name = "SST25LF040A.RES",
.model_id = SST_SST25VF040_REMS,
SST25LF040A vs. SST25LF040, and RES vs. REMS. Not your fault, but we should fix that as well.
.name = "SST28SF040A",
.model_id = SST_SST28SF040,
SST28SF040A vs. SST28SF040.
Same problem for SST39SF010A/SST39SF010 and SST39SF020A/SST39SF020.
Side note: The Sanyo LF25FW203A has SANYO_LE25FW203A. Is "LE25" or LF25" correct?
Rest looks good. Not sure if we want to fix the problems above in a separate patch, and keep this patch a pure conversion with no semantic changes. IMHO the two-patch solution is better, so please commit this patch as-is.
Acked-by: Carl-Daniel Hailfinger c-d.hailfinger.devel.2006@gmx.net
Regards, Carl-Daniel
On Wed, Sep 15, 2010 at 17:49, Carl-Daniel Hailfinger c-d.hailfinger.devel.2006@gmx.net wrote:
On 15.09.2010 04:04, Mattias Mattsson wrote:
This patch changes the prefix of chip constant #defines in the following way:
AM_nnnnnnn -> AMD_AMnnnnnnn AT_nnnnnnn -> ATMEL_ATnnnnnnn EN_nnnnnnn -> EON_ENnnnnnnn MBMnnnnnnn -> FUJITSU_MBMnnnnnnn MX_ID -> MACRONIX_ID MX_nnnnnnn -> MACRONIX_MXnnnnnnn PMC_nnnnnnn -> PMC_PMnnnnnnn SST_nnnnnnn -> SST_SSTnnnnnnn
It leaves the Intel #defines alone because there is another pending patch for that: http://patchwork.coreboot.org/patch/1937/
Some background discussion here: http://www.flashrom.org/pipermail/flashrom/2010-July/004059.html
Signed-off-by: Mattias Mattsson vitplister@gmail.com
.name = "Am29LV081B",
- .model_id = AMD_AM29LV080B,
This looks odd. Chip name and model_id don't match.
EN25B*
The whole EN25B family seems to be in desperate need of FEATURE_EVIL_TWIN unless the IDs are incorrect. Admittedly your patch doesn't make it worse, but this area is in desperate need of fixing.
.name = "Pm39LV010",
- .model_id = PMC_PM39F010, /* Pm39LV010 and Pm39F010 have identical IDs but different voltage */
name/model_id mismatch. Besides that, we probably want all names in .name
.name = "SST25LF040A.RES",
- .model_id = SST_SST25VF040_REMS,
SST25LF040A vs. SST25LF040, and RES vs. REMS. Not your fault, but we should fix that as well.
.name = "SST28SF040A",
- .model_id = SST_SST28SF040,
SST28SF040A vs. SST28SF040.
Same problem for SST39SF010A/SST39SF010 and SST39SF020A/SST39SF020.
Side note: The Sanyo LF25FW203A has SANYO_LE25FW203A. Is "LE25" or LF25" correct?
Rest looks good. Not sure if we want to fix the problems above in a separate patch, and keep this patch a pure conversion with no semantic changes. IMHO the two-patch solution is better, so please commit this patch as-is.
Acked-by: Carl-Daniel Hailfinger c-d.hailfinger.devel.2006@gmx.net
Thanks, committed as r1175.
Also, many thanks for your comments! I will look at them separately.
-mattias