On 09.01.2010 01:44, Sean Nelson wrote:
On 1/7/2010 1:22 PM, Carl-Daniel Hailfinger wrote:
int probe_jedec(struct flashchip *flash) {
- return probe_jedec_common(flash, MASK_FULL, 1);
int mask;
mask = getaddrmask(flash);
return probe_jedec_common(flash, mask, 1); }
int erase_sector_jedec(struct flashchip *flash, unsigned int page,
unsigned int size)
Instead of having this wrapper, we could move getaddrmask into probe_jedec_common and revert the name of probe_jedec_common too.
My idea was to allow semi-converted flash chip drivers (drivers which should use the JEDEC stuff but are instead calling the _jedec_common functions with hand-crafted masks). You do have a point, but I didn't just want to waltz in and revert parts of your _jedec_common infrastructure.
But, this is fine. Acked-by: Sean Nelson audiohacked@gmail.com
Thanks, r840.
Regards, Carl-Daniel