On 1/7/2010 1:22 PM, Carl-Daniel Hailfinger wrote:
int probe_jedec(struct flashchip *flash) {
- return probe_jedec_common(flash, MASK_FULL, 1);
int mask;
mask = getaddrmask(flash);
return probe_jedec_common(flash, mask, 1); }
int erase_sector_jedec(struct flashchip *flash, unsigned int page, unsigned int size)
Instead of having this wrapper, we could move getaddrmask into probe_jedec_common and revert the name of probe_jedec_common too.
But, this is fine. Acked-by: Sean Nelson audiohacked@gmail.com