On Sun, 14 Jul 2013 01:41:51 +0200 Carl-Daniel Hailfinger c-d.hailfinger.devel.2006@gmx.net wrote:
I already mentioned the suboptimal file name and public function names on IRC. You said: "[...] best would be to name it amd_imc.c and name the one external visible function amd_imc_shutdown [...]" That change would be appreciated.
already done locally and on github ;)
diff --git a/chipset_enable.c b/chipset_enable.c index 3979347..c884c80 100644 --- a/chipset_enable.c +++ b/chipset_enable.c @@ -922,6 +922,10 @@ static int enable_flash_sb600(struct pci_dev *dev, const char *name) uint8_t reg; int ret;
- if (imc_shutdown(dev) != 0) {
Hm. Can we avoid calling this on SB600 (if SB600 doesn't support IMC at all)?
i would rather postpone this for sb600spi.c refactoring where i would like to see some differentiation like in ichspi.c. there are many small differences which we pretty much ignored so far... but i wondered a few times if this is the right place to call it. why not in sb600_probe_spi() for example?