I missed the reason you wanted the name changed; I commented at the time that for IEEE 1275, the name property at the root node is supposed to be the platform name. Why do you want it called "device-tree", which would certainly be incorrect?
To match Apple's implementation which is expected my at least one client. Sould I enclose it in CONFIG_PPC or some other ifdefs? Would that make it better?
Regards, BALATON Zoltan